You must update existing vRealize Automation 7.1, 7.2, 7.3 or 7.3.1 templates after you complete migration to 7.4 so that the Software Agents use the TLS 1.2 protocol.

About this task

Guest agent and agent bootstrap code must be updated in the source environment templates. If you are using a linked clone option, you might need to remap the templates with the newly created virtual machines and their snapshots.

To upgrade your templates, you complete these tasks.

  1. Log in to vSphere.

  2. Convert each template from vRealize Automation 7.1, 7.2, 7.3 or 7.3.1 to a virtual machine and power on the machine.

  3. Import the appropriate software installer and run the software installer on each virtual machine.

  4. Convert each virtual machine back to a template.

Use this procedure to locate the software installers for Linux or Windows.

Prerequisites

  • Apply Software Agent Patch if you migrated from vRealize Automation 7.1, or 7.3 to 7.4.

  • Successful migration from vRealize Automation 7.1, 7.2, 7.3 or 7.3.1 to 7.4.

Procedure

  1. Start a browser and open the vRealize Automation 7.4 appliance splash page using the fully qualified domain name of the virtual appliance: https://vra-va-hostname.domain.name.
  2. Click Guest and software agents page.
  3. Follow the instructions for the Linux or Windows software installers.

What to do next

Identify Virtual Machines that Need Software Agent Upgrade.