Users can view the duplicate record of resources when the ServiceNow environment is domain separated.

Problem

For domain separated ServiceNow environment, the user can view the duplication of resources in both the Global domain and the end-user domain after running the vRA Import resources and CMDB job schedule. This is a known issue that occurred in 8.7 and the problem is fixed in 8.8.

Cause

This problem occurs due to default IRE (Identification and Reconciliation engine) behavior being in strict mode for domain separation. In this mode, identification processes only those CIs in which the domain ID is identical to the domain of the currently logged-in user. If duplicate CIs exist across the domains (including parent and child domains), then those CIs are not considered duplicate CIs because their domain IDs are unmatched. Hence the user will see the duplicate record of the requested resources.

Solution

To fix the duplication issue in 8.7, when the user requests resources, perform the following steps:

  1. Log in to ServiceNow as the system administrator.

  2. Find the resources which belong to the end user's domain.

  3. Delete each resource.