vRealize Business for Cloud is unable to collect data from vCenter Server.
For more information, see the knowledge base article at http://kb.vmware.com/kb/2146836.
Problem
When you click Status on the vRealize Business for Cloud user interface, you see one of the following problems:
- You see the red icon for the vCenter Server status.
- You see a vCenter Server synchronization failure message.
- You see the following error message under vCenter Server section:
Unable to retrieve data from vROps vrops_server_address
- When you click Status on the vRealize Business for Cloud user interface, you see the following error message under vCenter Server:
Unable to authenticate to vROps vrops_server_address using the vCenter's credentials
Cause
This issue might occur in one of the following situations.
- The time zone of the vRealize Business for Cloud virtual appliance is not in the UTC format.
- The vCenter Server, Web services, and profile driven services are not running under the same LocalSystem or domain account.
- The vRealize Operations Manager server is not reachable.
- The vRealize Operations Manager API service is failing.
- The vRealize Operations Manager server is on an HA clustered, multi-node environment, and the node registered with vCenter Server is not reachable.
- Individual vCenter Server user login is disabled in vRealize Operations Manager.
Solution
- ♦ To resolve this problem, perform the applicable step out of the following solutions.
- Change the time zone to a UTC format in the vRealize Business for Cloud virtual machine. and run the
monit restart itbm-server
command. - Verify that all vCenter Server services such as, inventory, stats, and storage profiles run under the same user account.
- If the vCenter Server has been added to vRealize Operations Manager in the last 24 hours, wait for vRealize Operations Manager to compute all data before attempting data collection again.
- Check for any problems with the vRealize Operations Manager API service and resolve them.
- If the vRealize Operations Manager instance is a multi-node setup and if a new node has been deployed to replace the failed node, update the plug-in on vRealize Operations Manager to register the new node with vCenter Server.
- Enable the individual log in option in the vRealize Operations Manager instance.
Click
.
- Change the time zone to a UTC format in the vRealize Business for Cloud virtual machine. and run the