vRealize Business for Cloud reports insufficient storage for large public cloud bills.
Problem
If the size of the unzipped file of AWS or Azure bill is large, the virtual appliance runs out of storage and fails to store the bill.
Cause
This problem occurs when the unzipped file of AWS or Azure Bill is large. The lack of hard disk space affects the data collection process and other processes which need storage access.
Solution
- Shut down the vRealize Business for Cloud appliance.
- Add a new hard disk to the vRealize Business for Cloud.
- Power on the virtual appliance.
- Connect to the virtual appliance using the Secure Sockets Layer.
- In the shell client, to List all disks and identify the device ID of the new disk added, run fdisk -lu.
Note: By default, the device ID for the new disk is
/dev/sdb
.
- Access the disk utility for the new disk and run the fdisk /dev/sdb command.
- Press n then press Enter for new partition.
- Press p then press Enter for primary partition.
- Press 1 as the partition number.
- Accept the default start block and the default end block(use the default by pressing enter twice for start and for end).
- Press w to write the partition table to disk.
- Create a partition on the new disk.
- To create an ext3 file system on the new disk, run mkfs -t ext3 /dev/sdb1.
- If the bill size of AWS or Azure is large, run mount /dev/sdb1 /usr/local/tomcat/itbm-data-collector/temp/ to mount the data-collector to a temp location in the new disk.
- Run mount -l.
The command confirms whether the new partition is mounted properly or not. See whether the output contains
/dev/sdb1 on /usr/local/tomcat/itbm-data-collector/temp type ext3 (rw,relatime,data=ordered)
or not.
- To open the file using vi, run vi /etc/fstab.
- Add /dev/sdb1 /usr/local/tomcat/itbm-data-collector/temp ext3 defaults 1 1.
This step ensures that the disk is not unmounted if the virtual appliance is restarted.
Solution
Increase the size of vRealize Business for Cloud virtual appliance.