Unable to authenticate with a OAuthToken exception in Business management tab of vRealize Business for Cloud integrated with vRealize Automation

Problem

When you attempt to access the Business Management tab in vRealize Business for Cloud which is integrated with vRealize Automation, the following authentication exception message is displayed. org.springframework.security.authentication.BadCredentialsException: Unable to authenticate with OAuthToken! The token is expired.

Cause

This issue occurs in vRealize Automation. When the user session expires in vRealize Automation, business management tab displays the authentication exception.

Solution

  • In vRealize Automation mode, after token expiry if the authentication exception pop-up appears in Business Management, then log out and log in again.