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Updated Information
The following table lists the changes to Installing vRealize Code Stream for this product release.
Revision
28 JULY 2017

01 JAN 2017

VMware, Inc.

Description
n

Updated screenshot, text, and steps in Apply a vRealize Code Stream License to an Appliance.

n

Updated screenshot and text in Chapter 1 vRealize Code Stream Installation.

Initial release.
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About vRealize Code Stream Installation
and Configuration
The Installation and Configuration guide provides information about how to install and configure
vRealize Code Stream to automate the release of applications. In this guide, vRealize Automation
appliance refers to the underlying appliance with the minimum set of common services required to use
thevRealize Code Stream application and vRealize Automation refers to the complete set of capabilities
offered by the vRealize Automation product. This guide provides installation tasks that you must perform
for both vRealize Automation and vRealize Code Stream.

Intended Audience
This information is intended for anyone who wants to install vRealize Code Stream, and configure the
environment to automate the release applications in development environments. The information is
written for experienced developers and operation teams who are familiar with release automation of
applications to production environments.

VMware Technical Publications Glossary
VMware Technical Publications provides a glossary of terms that might be unfamiliar to you. For
definitions of terms as they are used in VMware technical documentation, go to
http://www.vmware.com/support/pubs.

VMware, Inc.
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1

vRealize Code Stream shares a platform and some common services with vRealize Automation and is
delivered in the same virtual appliance.
By entering the appropriate license keys, a System Administrator can unlock either vRealize Automation,
vRealize Code Stream, or both products on the same appliance.

Installing vRealize Code Stream
To install vRealize Code Stream, you must:
n

Deploy and configure a vRealize Automation appliance.

n

Apply a vRealize Code Stream license.

n

Configure a tenant to assign user roles in vRealize Code Stream.

Caution Although you can enable vRealize Code Stream on the same virtual appliance as
vRealize Automation in lab or evaluation environments, it is not a supported configuration for production
systems. This requirement is important when vRealize Automation is configured in High Availability (HA)
mode. This version of vRealize Code Stream does not support HA configuration. If you enable
vRealize Code Stream on a vRealize Automation instance that runs in HA mode, doing so can put the
overall system in an unpredictable state.
If you enabled vRealize Code Stream on a vRealize Automation instance in HA mode, and encountered
problems, see the VMware knowledge base article at https://kb.vmware.com/kb/2145084 to resolve those
problems. If you have further questions, contact VMware Global Support Services.

Licensing vRealize Code Stream
You can have the vRealize Automation appliance run vRealize Code Stream.
Caution Before you enable vRealize Code Stream, verify that High Availability (HA) is not running on
the vRealize Automation appliance.
To enable vRealize Code Stream, in the vRealize Automation installation wizard, select the Enable
vRealize Code Stream check box.

VMware, Inc.
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Important If you apply your license without enabling vRealize Code Stream, you can enable
vRealize Code Stream later. Apply the license again, and select Enable vRealize Code Stream.
The selection to enable vRealize Code Stream also appears on the Licensing tab in the
vRealize Automation appliance. See Apply a vRealize Code Stream License to an Appliance.
This chapter includes the following topics:
n

Preparing for Installation

n

Installation Checklist for Using vRealize Code Stream

n

Installation Worksheet

n

Installing vRealize Code Stream With the Installation Wizard

n

Installing vRealize Code Stream Through the Standard Interfaces

n

Apply a vRealize Code Stream License to an Appliance

Preparing for Installation
System Administrators install vRealize Code Stream into their existing virtualization environments. Before
you begin an installation, prepare the deployment environment to meet system requirements.

DNS and Host Name Resolution
vRealize Code Stream requires the system administrator to identify all hosts by using a fully qualified
domain name (FQDN).
Important vRealize Code Stream does not allow navigation to hosts that contain the underscore (_)
character in the host name.

VMware, Inc.
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Hardware and Virtual Machine Requirements
The virtual appliances are pre-configured virtual machines that you add to your vCenter Server or ESXi
inventory.
For operating system and high-level environment requirements, including information about supported
browsers and operating systems, see the vRealize Automation Support Matrix.
An Active Directory is considered small when there are up to 25,000 users in the Organizational Unit (OU)
to be synced in the ID Store configuration. An Active Directory is considered large when there are more
than 25,000 users in the OU.
The hardware requirements for vRealize Code Stream for Small Active Directories are:
n

4 CPUs

n

18-GB memory

n

60-GB disk storage

Password Considerations
Character restrictions apply to some passwords.
The vRealize Code Stream administrator password is subject to the following restrictions:
n

Cannot contain a trailing "=" character. Such passwords are accepted when you assign them, but
result in errors when you perform operations such as saving endpoints.

n

Cannot contain non-ASCII or extended ASCII characters.

n

Cannot contain a comma or have a space between characters.

Port Requirements
vRealize Code Stream uses designated ports for communication and data access.
Although vRealize Code Stream uses only port 443 for communication, there might be other ports open
on the system. Because open, unsecure ports can be sources of security vulnerabilities, review all open
ports on your system and ensure that only the ports that are required by your business applications are
open.

vRealize Automation Appliance
The following ports are used by the vRealize Appliance.
Table 1‑1. Incoming Ports for the vRealize Appliance
Port

Protocol

Comments

22

TCP

Optional. SSH.

80

TCP

Optional. Redirects to 443.

111

TCP, UDP

RPC

VMware, Inc.
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Table 1‑1. Incoming Ports for the vRealize Appliance (Continued)
Port

Protocol

Comments

443

TCP

Access to the vRealize Automation console and API calls.

5480

TCP

Access to virtual appliance Web management interface

5480

TCP

Used by Management Agent

5488, 5489

TCP

Internal. Used by vRealize Appliance for updates.

4369,
25672,5671,5672

TCP

RabbitMQ messaging

8230, 8280, 8281

TCP

Internal vRealize Orchestrator instance

8444

TCP

Console proxy communication for vSphere VMware Remote Console connections

Table 1‑2. Outgoing Ports for the vRealize Automation Appliance
Port

Protocol

Comments

25, 587

TCP, UDP

SMTP for sending outbound notification emails

53

TCP, UDP

DNS

67, 68, 546, 547

TCP, UDP

DHCP

80

TCP

Optional. For fetching software updates. Updates can be downloaded separately and
applied.

110, 995

TCP, UDP

POP for receiving inbound notification emails

143, 993

TCP, UDP

IMAP for receiving inbound notification emails

123

TCP, UDP

Optional. For connecting directly to NTP instead of using host time.

902

TCP

ESXi network file copy operations and VMware Remote Console (VMRC) connections

5432

TCP, UDP

Optional. For communicating with an Appliance Database.

7444

TCP

Communication with SSO service over HTTPS

8281

TCP

Optional. For communicating with an external vRealize Orchestrator instance .

Other ports might be required by specific vRealize Orchestrator plug-ins that communicate with external
systems. See the documentation for the vRealize Orchestrator plug-in.

User Accounts and Credentials Required for Installation
You must verify that you have the roles and credentials to install vRealize Code Stream components.

Virtual Appliance Installation
To deploy the vRealize Appliance, you must have the appropriate privileges on the deployment platform
(for example, vSphere administrator credentials).
During the deployment process, you specify the password for the virtual appliance administrator account.
This account provides access to the vRealize Appliance management console from which you configure
and administer the virtual appliances.

VMware, Inc.
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Security
vRealize Code Stream uses SSL to ensure secure communication among components. Passphrases are
used for secure database storage.

vRealize Code Stream Certificates
vRealize Code Stream uses SSL certificates for secure communication. You can obtain certificates from
an internal or external certificate authority, or generate self-signed certificates during the deployment
process for each component.
For important information about troubleshooting, supportability, and trust requirements for certificates, see
the VMware knowledge base article at http://kb.vmware.com/kb/2106583.
You can update or replace certificates after deployment. For example, a certificate may expire or you may
choose to use self-signed certificates during your initial deployment, but then obtain certificates from a
trusted authority before going live with your vRealize Code Stream implementation. When you do a
minimal deployment, you can generate a self-signed certificate during vRealize Code Stream Appliance
configuration.
Certificate Chains
If you use certificate chains, specify the certificates in the following order:
n

Client-server certificate signed by the intermediate CA certificate

n

One or more intermediate certificates

n

A root CA certificate

Include the BEGIN CERTIFICATE header and END CERTIFICATE footer for each certificate when you
import certificates.

Extracting Certificates and Private Keys
Certificates that you use with the virtual appliances must be in the PEM file format.
The examples in the following table use Gnu openssl commands to extract the certificate information you
need to configure the virtual appliances.
Table 1‑3. Sample Certificate Values and Commands (openssl)
Certificate Authority Provides

Command

Virtual Appliance Entries

RSA Private Key

openssl pkcs12 -in path _to_.pfx
certificate_file -nocerts -out key.pem

RSA Private Key

PEM File

openssl pkcs12 -in path _to_.pfx
certificate_file -clcerts -nokeys -out
cert.pem

Certificate Chain

(Optional) Pass Phrase

n/a

Pass Phrase

VMware, Inc.
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Security Passphrase
vRealize Code Stream uses security passphrases for database security. A passphrase is a series of
words used to create a phrase that generates the encryption key that protects data while at rest in the
database.
Follow these guidelines when creating a security passphrase for the first time.
n

Use the same passphrase across the entire installation to ensure that each component has the same
encryption key.

n

Use a phrase that is greater than eight characters long.

n

Include uppercase, lowercase and numeric characters, and symbols.

n

Memorize the passphrase or keep it in a safe place. The passphrase is required to restore database
information in the event of a system failure or to add components after initial installation. Without the
passphrase, you cannot restore successfully.

Time Synchronization
Time synchronization is crucial for the secure communication across systems. A system administrator
must set up accurate timekeeping as part of the vRealize Code Stream installation.
Installation fails if time synchronization is set up incorrectly.
Timekeeping must be consistent and synchronized across the vRealize Code Stream and remote
vRealize Automation servers. By using the same timekeeping method for each component, you can
ensure this consistency.
For virtual machines, you can use the following methods:
n

Configuration by using Network Time Protocol (directly)

n

Configuration by using Network Time Protocol through ESXi with VMware Tools. You must have NTP
set up on the ESXi.

For Windows servers, consult Timekeeping best practices for Windows, including NTP.

Installation Checklist for Using vRealize Code Stream
The installation checklist provides a high-level overview of the sequence of tasks you must perform to
complete the vRealize Code Stream installation.

Installation Checklist
Use the checklist to track your work as you complete the installation tasks in the order they are listed.

VMware, Inc.
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Table 1‑4. Installation Tasks
Task

Details

Complete the installation worksheet

Installation Worksheet

Deploy the vRealize Automation appliance

Deploy the vRealize Automation Appliance

Set up the vRealize Automation appliance

Configure the vRealize Appliance

Add the vRealize Code Stream license key

Apply a vRealize Code Stream License to an Appliance

Configure Tenant

See the vRealize Automation Information Center.

Add vRealize Code Stream roles

Assign Roles to Directory Users or Groups
Assign the Release Manager, Release Engineer, and Release
Dashboard user roles for modeling and publishing a pipeline.

Installation Worksheet
You can use this worksheet to record important information for reference during the installation process.
The settings that you provide are case sensitive.
Table 1‑5. vRealize Appliance Information
Variable

Value

Example

Host Name (FQDN)

vrcs-va.mycompany.com

IP

192.168.1.105

Username

administrator@vsphere.local (default)

Password

administrator@vsphere.local
vmware

Installing vRealize Code Stream With the Installation
Wizard
The Installation Wizard for vRealize Automation provides a simple and fast way to install minimal or
enterprise deployments.
You must deploy a vRealize Appliance before you begin the wizard.

Wizard Navigation
The Installation Wizard appears the first time you log in to your vRealize Appliance. If you want to stop
the wizard and return later, log out with the Logout button that appears on each screen. Use the Cancel
button to exit the wizard and install through the management console.
Use the Previous and Next buttons to navigate through wizard screens.

VMware, Inc.
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Deploy the vRealize Automation Appliance
To deploy the vRealize Appliance, a system administrator must log in to the vSphere client and select
deployment settings.
Some restrictions apply to the root password you create for the vRealize Automation administrator.
For more information, see Password Considerations.
Prerequisites
n

Download the vRealize Automation appliance from the VMware Web site.

n

Log in to the vSphere client as a user with system administrator privileges.

Procedure

1

Select File > Deploy OVF Template from the vSphere client.

2

Browse to the vRealize Automation appliance file you downloaded and click Open.

3

Click Next.

4

Click Next on the OVF Template Details page.

5

Accept the license agreement and click Next.

6

Enter a unique virtual appliance name according to the IT naming convention of your organization in
the Name text box, select the datacenter and location to which you want to deploy the virtual
appliance, and click Next.

7

Follow the prompts until the Disk Format page appears.

8

Verify on the Disk Format page that enough space exists to deploy the virtual appliance and click
Next.

9

Select the disk format. For example, Thin Provisioning.

10 Follow the prompts to the Properties page.
The options that appear depend on your vSphere configuration.
11 Configure the values on the Properties page.
a

Enter the root password to use when you log in to the virtual appliance console in the Enter
password and Confirm password text boxes.

b

Select or uncheck the SSH service checkbox to choose whether SSH service is enabled for the
appliance.
This value is used to set the initial status of the SSH service in the appliance. If you are installing
with the Installation Wizard, enable this before you begin the wizard. You can change this setting
from the appliance management console after installation.

c

Enter the fully qualified domain name of the virtual machine in the Hostname text box.

d

Configure the networking properties.

VMware, Inc.
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12 Click Next.
13 Depending on your vCenter and DNS configurations, it could take some time for the DNS to resolve.
To expedite this process, perform the following steps.
n

If Power on after deployment is available on the Ready to Complete page.
a

Select Power on after deployment and click Finish.

b

Click Close after the file finishes deploying into vCenter.

c

Wait for the machine to start.
This could take up to 5 minutes.

n

If Power on after deployment is not available on the Ready to Complete page.
a

Click Close after the file finishes deploying into vCenter.

b

Power on the VM and wait for some time for the VM to start up.

c

Verify that you can ping the DNS of the virtual machine. If you cannot ping the DNS, restart
the virtual machine.

d

Wait for the machine to start. This could take up to 5 minutes.

14 Open a command prompt and ping the FQDN to verify that the fully qualified domain name can be
resolved against the IP address of vRealize Automation appliance.

Run the Installation Wizard for a Minimal Deployment
Set up a single vRealize Appliance to install vRealize Code Stream.
The wizard is disabled when you click Cancel, or when you log out of the wizard and begin an installation
through the management console.
Procedure

1

Open a Web browser.

2

Navigate to the vRealize Automation management console by using its fully qualified domain name,
https://vrcs-vahostname.domain.name:5480/.

3

Log in with the user name root and the password you entered when you deployed the appliance.

4

When the Installation Wizard appears, click Next.

5

Accept the End-User License Agreement and click Next.

6

Select Minimal Deployment and unselect Install Infrastructure as a Service on the Deployment
Type screen and click Next.

7

If needed, you can change the timekeeping method for your vRealize Automation appliance. Click
Change Time Settings, if you make changes.

8

Select Resolve Automatically to select the host.

9

Enter the administration password, confirm the password, and click Next.

VMware, Inc.
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10 Submit the vRealize Appliance Certificate information such as Organization, Organizational Unit, and
Country code.
11 Click Save Generated Certificate and click Next.
12 Click Install.
13 Enter a valid vRealize Code Stream license key and click Submit Key.
14 Click the Telemetry tab to choose whether to join the VMware Customer Experience Improvement
Program (CEIP).
Details regarding the data collected through CEIP and the purposes for which it is used by VMware
are given at the Trust & Assurance Center at http://www.vmware.com/trustvmware/ceip.html.
15 (Optional) Select Join the VMware Customer Experience Improvement Program to participate in
the program and click Next.
16 Click Next, and click Finish
17 Confirm that you can log in to the vRealize Automation console.
a

Open a Web browser.

b

Navigate to https://vrcs-hostname.domain.name/vcac.

Installing vRealize Code Stream Through the Standard
Interfaces
As an alternative to the Installation Wizard, you can install vRealize Code Stream through the
vRealize Automation appliance management console.
Installation through the standard interface is intended primarily for minimal deployment.

Minimal Deployment Checklist
A system administrator can deploy complete product in a minimal configuration. Minimal deployments are
typically used in a development environment or as a proof of concept and require fewer steps to install.
The Minimal Deployment Checklist provides a high-level overview of the sequence of tasks you must
perform to complete a minimal installation.
Print out a copy of the checklist and use it to track your work as you complete the installation. Complete
the tasks in the order in which they are given.
Table 1‑6. Minimal Deployment Checklist

VMware, Inc.

Task

Details

Plan and prepare the installation environment and verify that
all installation prerequisites are met.

Password Considerations

Set up your vRealize Appliance

Deploy and Configure the vRealize Automation
Appliance
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Deploy and Configure the vRealize Automation Appliance
The vRealize Appliance is a preconfigured virtual appliance that deploys the vRealize Appliance server
and Web console (the user portal). It is delivered as an open virtualization format (OVF) template. The
system administrator downloads the appliance and deploys it into the vCenter Server or ESX/ESXi
inventory.

Deploy the vRealize Automation Appliance
To deploy the vRealize Appliance, a system administrator must log in to the vSphere client and select
deployment settings.
Some restrictions apply to the root password you create for the vRealize Automation administrator.
For more information, see Password Considerations.
Prerequisites
n

Download the vRealize Automation appliance from the VMware Web site.

n

Log in to the vSphere client as a user with system administrator privileges.

Procedure

1

Select File > Deploy OVF Template from the vSphere client.

2

Browse to the vRealize Automation appliance file you downloaded and click Open.

3

Click Next.

4

Click Next on the OVF Template Details page.

5

Accept the license agreement and click Next.

6

Enter a unique virtual appliance name according to the IT naming convention of your organization in
the Name text box, select the datacenter and location to which you want to deploy the virtual
appliance, and click Next.

7

Follow the prompts until the Disk Format page appears.

8

Verify on the Disk Format page that enough space exists to deploy the virtual appliance and click
Next.

9

Follow the prompts to the Properties page.
The options that appear depend on your vSphere configuration.

VMware, Inc.
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10 Configure the values on the Properties page.
a

Enter the root password to use when you log in to the virtual appliance console in the Enter
password and Confirm password text boxes.

b

Select or uncheck the SSH service checkbox to choose whether SSH service is enabled for the
appliance.
This value is used to set the initial status of the SSH service in the appliance. If you are installing
with the Installation Wizard, enable this before you begin the wizard. You can change this setting
from the appliance management console after installation.

c

Enter the fully qualified domain name of the virtual machine in the Hostname text box.

d

Configure the networking properties.

11 Click Next.
12 Depending on your vCenter and DNS configurations, it could take some time for the DNS to resolve.
To expedite this process, perform the following steps.
n

If Power on after deployment is available on the Ready to Complete page.
a

Select Power on after deployment and click Finish.

b

Click Close after the file finishes deploying into vCenter.

c

Wait for the machine to start.
This could take up to 5 minutes.

n

If Power on after deployment is not available on the Ready to Complete page.
a

Click Close after the file finishes deploying into vCenter.

b

Power on the VM and wait for some time for the VM to start up.

c

Verify that you can ping the DNS of the virtual machine. If you cannot ping the DNS, restart
the virtual machine.

d

Wait for the machine to start. This could take up to 5 minutes.

13 Open a command prompt and ping the FQDN to verify that the fully qualified domain name can be
resolved against the IP address of vRealize Automation appliance.

Enable Time Synchronization on the vRealize Automation Appliance
To ensure a successful installation, enable time synchronization on the Clocks on the
vRealize Automation Appliance.
If you see certificate warnings during this process, continue past them to finish the installation.
Prerequisites

Deploy the vRealize Automation Appliance.

VMware, Inc.
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Procedure

1

Navigate to the vRealize Automation management console by using its fully qualified domain name,
https://vrcs-vahostname.domain.name:5480/.

2

Log in with the user name root and the password you entered when you deployed the appliance.

3

Select Admin > Time Settings.

4

Select an option from the Time Sync Mode menu.
Option

Action

Use Time Server

Select Use Time Server from the Time Sync Mode menu to use Network Time
Protocol . For each time server that you are using, enter the IP address or the
host name in the Time Server text box.

Use Host Time

Select Use Host Time from the Time Sync Mode menu to use VMware Tools
time synchronization. You must configure the connections to Network Time
Protocol servers before you can use VMware Tools time synchronization.

5

Click Save Settings.

6

Click Refresh.

7

Verify that the value in Current Time is correct.
You can change the time zone as required from the Time Zone Setting page on the System tab.

8

(Optional) Click Time Zone from the System tab and select a system time zone from the menu
choices.
The default is Etc/UTC.

9

Click Save Settings.

Configure the vRealize Appliance
To prepare the vRealize Appliance for use, a system administrator configures the host settings, generates
an SSL certificate, and provides SSO connection information.
Procedure

1

Navigate to the vRealize Automation management console by using its fully qualified domain name,
https://vrcs-vahostname.domain.name:5480/.

2

Continue past the certificate warning.

3

Log in with user name root and the password you specified when you deployed vRealize Appliance.

VMware, Inc.
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4

Select vRA Settings > Host Settings
Option

Action

Resolve Automatically

Select Resolve Automatically to specify the name of the current host for the
vRealize Automation appliance.

Update Host

For new hosts, select Update Host. Enter the fully qualified domain name of the
vRealize Automation appliance, vrcs-hostname.domain.name, in the Update
Host text box.

Note Configure SSO settings as described later in this procedure whenever you use Update Host
to change a host name.
5

Select the certificate type from the Certificate Action menu.
If you are using a PEM-encoded certificate, for example for a distributed environment, select Import.
Certificates that you import must be trusted and applicable to all instances of vRealize Appliance by
using Subject Alternative Name (SAN) certificates.
Note If you use certificate chains, specify the certificates in the following order:
a

Client-server certificate signed by the intermediate CA certificate

b

One or more intermediate certificates

c

A root CA certificate

Option

Action

Keep Existing

Leave the current SSL configuration. To cancel your changes, select this option.

Generate Certificate

a

The value displayed in the Common Name text box is the Host Name as it
appears on the upper part of the page. If additional instances of the vRealize
Appliance available, their FQDNs are included in the SAN attribute of the
certificate.

b

Enter your organization name, such as your company name, in the
Organization text box.

c

Enter your organizational unit, such as your department name or location, in
the Organizational Unit text box.

d

Enter a two-letter ISO 3166 country code, such as US, in the Country text
box.

Import

a

Copy the certificate values from BEGIN PRIVATE KEY to END PRIVATE KEY,
including the header and footer, and paste them in the RSA Private Key text
box.

b

Copy the certificate values from BEGIN CERTIFICATE to END
CERTIFICATE, including the header and footer, and paste them in the
Certificate Chain text box. For multiple certificate values, include a BEGIN
CERTIFICATE header and END CERTIFICATE footer for each certificate.
Note For chained certificates, additional attributes may be available.

c

VMware, Inc.

(Optional) If your certificate uses a pass phrase to encrypt the certificate key,
copy the pass phrase and paste it in the Passphrase text box.
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6

Click Save Generated Certificate if you have selected the follow the Generated Certificate option.

7

Follow the on-screen prompts if you have selected the Keep Existing option.

8

Enter a new license key for vRealize Code Stream.

9

Click Submit Key and click Next.

10 Click the Telemetry tab to choose whether to join the VMware Customer Experience Improvement
Program (CEIP).
Details regarding the data collected through CEIP and the purposes for which it is used by VMware
are given at the Trust & Assurance Center.
11 (Optional) Select Join the VMware Customer Experience Improvement Program to participate in
the program and click Next.
12 Click Next, and click Finish.

Apply a vRealize Code Stream License to an Appliance
When you apply the vRealize Code Stream standalone license to a vRealize Automation appliance, you
enable the vRealize Code Stream capabilities.
You can use the vRealize Code Stream standalone license to enable pipeline modeling, pipeline
execution, and the release dashboard.
You can have the vRealize Automation appliance run vRealize Code Stream by selecting the Enable
vRealize Code Stream check box when you submit the license key.

VMware, Inc.
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This selection also appears in the vRealize Code Stream Installation Wizard. See Chapter 1 vRealize
Code Stream Installation.
Caution Before you enable vRealize Code Stream, verify that High Availability (HA) is not running on
the vRealize Automation appliance.
Important If you apply your license without enabling vRealize Code Stream, you can enable
vRealize Code Stream later. Apply the license again, and select Enable vRealize Code Stream.
Prerequisites

Verify that the vRealize Automation appliance is set up. See Configure the vRealize Appliance.
Procedure

1

Open the vRealize Automation Appliance management console with the fully qualified domain name,
https:// vrcs-va-hostname.domain.name:5480/.

2

Log in as the root user.

3

Select vRA Settings > Licensing.

4

Enter a valid vRealize Code Stream license key and click Submit Key.

5

Select the Enable vRealize Code Stream check box.

6

Wait for 5 minutes for the services to start, and for the tenant administrator to log in and assign the
Release Manager and Release Engineer roles to users.
When the services have started, in the Virtual Appliance Management Interface (VAMI) Services you
can confirm that the release-management service is registered.

7

After the admin assigns the Release Manager and Release Engineer, confirm that you can log in to
the vRealize Automation console and see the Code Stream tab.
a

Open a Web browser.

b

Navigate to https://vrcs-hostname.domain.name/vcac.
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2

You must configure components such as vRealize Automation tenants, and assign roles to the identity
store before you can use vRealize Code Stream.
You create the default tenant when you install vRealize Automation, but you can create more tenants to
represent business units in an enterprise or companies that subscribe to cloud services from a service
provider. For more information on configuring tenants, see Installing vRealize Automation in the
vRealize Automation Information Center.

Managing Users
Tenant administrators create and manage custom groups and grant and manage user access rights to the
vRealize Automation console.

Add Identity Store
vRealize Automation uses identity stores to authenticate users. Each tenant is associated with at least
one identity store when it is created, but you can add new ones if necessary.
When you delete an identity store, it removes the roles assigned to users from this store and from custom
groups. It also removes information about the services that are available to this user. Entries for
entitlements and business groups are not affected.
Prerequisites

Log in to the vRealize Automation console as a tenant administrator.
Procedure

1

Select Administration > Directories Management > Directories.

2

Click the Add icon (

3

Enter a name in the Name text box.

4

Select the type of the identity store from the Type drop-down menu.
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5

Enter the following Identify Store configuration options.
Option

Action

URL

Enter the URL for the identity store. For example, ldap://10.123.45.678:901.

Domain

Enter the domain for the identity store.

(Optional) Domain Alias

Enter the domain alias.

Login User DN

Enter the login user Distinguished Name. For example,
cn=demoadmin,ou=demo,dc=dev,dc=mycompany,dc=com.

Password

Enter the password for the identity store login user.

Group Search Base DN

Enter the group search base Distinguished Name. For example,
ou=demo,dc=dev,dc=mycompany,dc=com.

User Search Base DN

Enter the user search base Distinguished Name.

6

Click Test Connection.

7

Click Add.

What to do next

Assign Roles to Directory Users or Groups.

Assign Roles to Directory Users or Groups
Tenant administrators grant access rights to users by assigning roles to users or groups.
To allow users or groups to modify and trigger a pipeline, you must assign permissions to those users and
groups. When you assign users and groups the role of Release Manager, they can modify and trigger the
pipeline. When you assign users and groups the role of Release Engineer, they can trigger the pipeline.
For more information, see the Using vRealize Code Stream guide.
Prerequisites

Log in to the vRealize Automation console as a tenant administrator.
Procedure

1

Select Administration > Users & Groups > Directory Users & Groups.

2

Enter a user or group name in the Search box and press Enter.
Do not use an at sign (@), backslash (\), or slash (/) in a name. You can optimize your search by
typing the entire user or group name in the form user@domain.

3

Click the name of the user or group to which you want to assign roles.

4

Select one or more roles from the Add Roles to this User list.
The Authorities Granted by Selected Roles list indicates the specific authorities you are granting.

5

(Optional) Click Next to view more information about the user or group.
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6

7

On the User Details page, on the General tab, scroll the list of roles to add the user.
a

To give the user permissions to modify and trigger a pipeline, select the Release Manager check
box.

b

To give the user permissions to trigger a pipeline, select the Release Engineer check box.

Click Update.

Users who are currently logged in to the vRealize Automation console must log out and log back in to the
vRealize Automation console before they can navigate to the pages to which they have been granted
access.
What to do next

Optionally, you can create your own custom groups from users and groups in your Active Directory
connections. See Create a Custom Group.

Create a Custom Group
Tenant administrators can create custom groups by combining other custom groups, identity store groups,
and individual identity store users.
You can assign roles to your custom group, but it is not necessary in all cases. For example, you can
create a custom group called Machine Specification Approvers, to use for all machine pre-approvals. You
can also create custom groups to map to your business groups so that you can manage all groups in one
place. In those cases, you do not need to assign roles.
Prerequisites

Log in to the vRealize Automation console as a tenant administrator.
Procedure

1

Select Administration > Users & Groups > Custom Groups.

2

Click the Add icon (

3

Enter a group name in the New Group Name text box.

).

Custom group names cannot contain the combination of a semicolon (;) followed by an equal sign (=).
4

(Optional) Enter a description in the New Group Description text box.

5

Select one or more roles from the Add Roles to this Group list.
The Authorities Granted by Selected Roles list indicates the specific authorities you are granting.

6

Click Next.
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7

Add users and groups to create your custom group.
a

Enter a user or group name in the Search box and press Enter.
Do not use an at sign (@), backslash (\), or slash (/) in a name. You can optimize your search by
typing the entire user or group name in the form user@domain.

b
8

Select the user or group to add to your custom group.

Click Add.

Users who are currently logged in to the vRealize Automation console must log out and log back in to the
vRealize Automation console before they can navigate to the pages to which they have been granted
access.

Manage User and Group Entitlements
You can use user and group directory name search parameters to control user and group entitlements.
For users or groups from other domains to have the expected system privileges, they must appear on the
following pages:
n

Administration > Users

n

Administration > Groups

If the users or groups do not have the expected privileges, review the search base distinguished name
parameters on the Identity Store Configuration page. Ensure that the distinguished name search
parameters are not so restrictive that the users and groups are excluded from the desired domains.
Prerequisites

Log in to vRealize Automation as a tenant administrator.
Procedure

1

Select Administration > Identity Stores.

2

Select the appropriate identity store and then click the Edit button.

3

Edit the group base distinguished name search parameters in the Group search base DN text box.
If users or groups do not possess adequate privileges, edit the search parameters to be less
restrictive.

4

Edit the user base distinguished name search parameters in the User search base DN text box.
If users or groups do not possess adequate privileges, edit the search parameters to be less
restrictive.

5

Click Test Connection.

6

Click Update.
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3

You must register various components, such as plug-ins and endpoints, before you can model and run
release pipelines in vRealize Code Stream.

Registering Plug-In Instances and Endpoints for a Release
Pipeline
To connect and interact vRealize Code Stream with external systems, you must install a plug-in. Each
plug-in that you install requires that you configure the endpoint and enter specific endpoint definitions. For
example, to provision a virtual machine, vRealize Code Stream requires a vRealize Automation endpoint
to facilitate the communication.
After you define and configure the plug-in endpoint, you can create a corresponding task in the release
pipeline. In the task, you define parameters. Then, when you execute a pipeline, you can access the
custom workflow in the vRealize Orchestrator client.
For example, a vRealize Automation endpoint allows for a provisioning task to be configured. A Jenkins
endpoint allows for a task to configure the Jenkins job as part of the pipeline template.
vRealize Code Stream supports the following endpoint types.
Table 3‑1. Endpoint Types
Endpoint Type

Details

Artifactory

Register an Artifactory Server Endpoint

Jenkins

Register a Jenkins Server Endpoint

vRealize Automation Server

Register a vRealize Automation Server Endpoint

vRealize Orchestrator Workflow for Task

Register a vRealize Orchestrator Workflow for a Task

vRealize Orchestrator Server

Register a vRealize Orchestrator Server Endpoint

vRealize Orchestrator Workflow for Gating Rule

Register a vRealize Orchestrator Workflow for a Gating Rule

Team Foundation Server

Register a Microsoft Team Foundation Server Endpoint

Cloud Foundry Server

Register a Cloud Foundry Server Endpoint

Bamboo Server

Register a Bamboo Server Endpoint

Bugzilla Server

Register a Bugzilla Server Endpoint

JIRA Server

Register a JIRA Server Endpoint
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Register an Artifactory Server Endpoint
To use an Artifactory server in a release pipeline, you must register and configure an Artifactory server
endpoint.
Artifact management persists the search criteria to find any artifacts from the Artifactory server. It allows
you to search the physical location and identity of artifacts, and supplies the required artifact during the
pipeline execution. With artifact management, you can specify an artifact by name and search type from
the server, but not by location or unique identifier.
Prerequisites
n

Verify that the Artifactory server is available and configured. See the Artifactory User Guide on the
jFrog website.

n

Verify that the Artifactory server version is 4.3.0 or later.

Procedure

1

Select Code Stream > Endpoints.

2

Click Add, and from the Endpoint Type drop-down menu select Artifactory.

3

Enter an Artifactory server endpoint name and an applicable description.
For example, in the description section you can add the release pipeline name that uses this
Artifactory server endpoint.

4

Enter the Artifactory server configuration details, and click Save.

The release pipeline can access the Artifactory server through the endpoint you created.
What to do next

To use this endpoint in the release pipeline, you must create a test task.
See Using vRealize Code Stream in the vRealize Code Stream Information Center.

Register a Jenkins Server Endpoint
You can run tests or other jobs by using the Jenkins plug-in that allows you to use custom automation and
scripts.
You can use any Jenkins job in the Jenkins server in the release pipeline with this endpoint enabled. You
can use this endpoint to invoke a Jenkins build job during the modeling of a release pipeline and run the
job as part of the release pipeline.
Prerequisites
n

Verify that the Jenkins server is available and configured.

n

Verify that the Jenkins server version is 1.561 or later.
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n

Verify that the Jenkins jobs are created in the Jenkins server with the input string parameter,
vRCSTestExecutionId.

Procedure

1

Select Code Stream > Endpoints.

2

Click Add.

3

Select Jenkins from the Endpoint Type drop-down menu.

4

Enter a Jenkins server endpoint name and an applicable description.
For example, in the description section you can add the release pipeline name that uses this Jenkins
server endpoint.

5

Enter the Jenkins server configuration details.
Option

Description

User Credentials

User name and password for the Jenkins server.

Folder Path

Enter the path of the folder used to group your jobs. Jenkins can run all jobs in the
folder.
n

You can create a folder under another folder. For example, Folder1 can
include job1.

n

Under Folder1, you can have another folder named Folder2, which includes
job2.

When you create an endpoint for Folder1, the folder path will be job/Folder1.
The endpoint will only list job1.
To obtain the list of jobs in the child folder named Folder2, you must create
another endpoint with the folder path as /job/Folder1/job/Folder2/.

6

URL

Enter the host URL as protocol://host:port. For example:
http://192.10.121.13:8080

Polling Interval

The interval duration for vRealize Code Stream to poll the Jenkins server for
updates.

Request Retry Count

Number of times to retry the scheduled build request for the Jenkins server.

Retry Wait Time

Seconds to wait before retrying the build request for the Jenkins server.

When the endpoint is created, you can select Offline Creation to require a validation and certificate
acceptance.
The offline creation allows you to create the endpoint when the server is not accessible. You can
accept the default setting, or select Yes to enable this configuration.

7

Click Save.

What to do next

To use this endpoint in the release pipeline, you must create a test task. See the Using vRealize Code
Stream guide.
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Register a vRealize Automation Server Endpoint
When you register a vRealize Automation, vRealize Code Stream invokes the vRealize Automation
instance to provision infrastructure in a specific environment
vRealize Code Stream can also invoke multiple vRealize Automation instances.
You must register a vRealize Automation server endpoint to provision a machine blueprint on
vRealize Automation.
Prerequisites
n

Log in to the vRealize Automation console as a release manager.

Procedure

1

Select Code Stream > Endpoints.

2

Click Add.

3

Select the vRealize Automation version from the Endpoint Type drop-down menu.

4

Enter a vRealize Automation endpoint name and an applicable description.

5

When the endpoint is created, you can select Offline Creation to require a validation and certificate
acceptance.
The offline creation allows you to create the endpoint when the server is not accessible. You can
accept the default setting, or select Yes to enable this configuration.

6

Click Save.

What to do next

To use this endpoint in the release pipeline, you must create a provision task. See the Using vRealize
Code Stream guide.

Register a vRealize Orchestrator Workflow for a Task
A release pipeline can configure a task to run a workflow that you create in the vRealize Orchestrator
service. The task can use either an embedded or an external instance of the vRealize Orchestrator
service.
You can use the embedded instance of the vRealize Orchestrator service, which is the instance that is
already running on the same appliance. When you use the embedded instance, an endpoint is not
needed.
You can also use an external instance of vRealize Orchestrator. When you use an external instance, you
must define an endpoint. You must also tag the workflow, and use the correct data types.
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Whether you use an embedded or external instance of the vRealize Orchestrator service, you must
register the workflow, and use the correct data types.
n

To register the vRealize Orchestrator service with vRealize Code Stream, you must tag the workflow
with the keyword named vRCS_CUSTOM. Untagged workflows do not appear in vRealize Code Stream.

n

Use only the string data type for the input and output properties. vRealize Code Stream cannot run
workflows that use complex data types, or any other data type.

Prerequisites

Verify that a workflow is created in vRealize Orchestrator.
Procedure

1

Log in to the vRealize Orchestrator client to create a workflow.

2

Select Library > Tagging > Tag workflow.
The Tag workflow is required for workflows. By default, the Manual Task workflow is provided.

3

Right-click Tag workflow and select Start Workflow.

4

To select the workflow, click the Tagged Workflow text box.
For example, the tagged workflow can be Deploy Spring Travel.

5

For the tag, enter vRCS_CUSTOM.

6

For the value, enter vRCS_CUSTOM.

7

For the Global tag, click Yes, and click Submit.

8

In vRealize Automation, click the Code Stream tab to continue with the task configuration.

Register a vRealize Orchestrator Server Endpoint
You can trigger workflows on an external vRealize Orchestrator from within a release pipeline.
Procedure

1

Select Code Stream > Endpoints.

2

Click Add.

3

Select vRealize Orchestrator External from the Endpoint Type drop-down menu.

4

Enter a vRealize Orchestrator server endpoint name and an applicable description.
For example, in the description section you can add the release pipeline name that uses this
vRealize Orchestrator server endpoint.
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5

6

Enter the vRealize Orchestrator server configuration details.
Option

Description

URL

Enter the host URL as protocol://host:port. For example:
http://192.10.121.13:8080

User Credentials

Enter the user name and password to connect to the vRealize Orchestrator
server.

Tenant

Enter the tenant group name.

When the endpoint is created, you can select Offline Creation to require a validation and certificate
acceptance.
The offline creation allows you to create the endpoint when the server is not accessible. You can
accept the default setting, or select Yes to enable this configuration.

7

Click Save.

What to do next

To use this endpoint in the release pipeline, you must create a task. See the Using vRealize Code Stream
guide.

Register a vRealize Orchestrator Workflow for a Gating Rule
A gating rule can invoke a custom workflow in the vRealize Orchestrator service.
Only an embedded instance of the vRealize Orchestrator service can be used for a gating workflow. Use
of an external instance is not supported.
You must register the gating workflow, and use the correct data types.
n

To register the gating workflow with vRealize Code Stream, you must tag the gating workflow with the
keyword named vRCS_GATING_RULE. Untagged workflows do not appear in vRealize Code Stream.

n

Use only the string data type for the input and output properties. vRealize Code Stream cannot
configure or run workflows that use complex data types, or any other data type.

Prerequisites

Verify that the workflow for a gating workflow is created.
Procedure

1

Log in to the vRealize Orchestrator client to create a gating workflow.

2

Select Library > Tagging > Tag workflow.

3

Right-click Tag workflow and select Start Workflow.

4

To select the gating workflow, click the Tagged Workflow text box.

5

For the tag, enter vRCS_GATING_RULE.

6

For the value, enter vRCS_GATING_RULE.
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7

For the Global tag, click Yes, and click Submit.

8

In vRealize Automation, click the Code Stream tab to continue with the task configuration.

Register a Microsoft Team Foundation Server Endpoint
You can connect to the Team Foundation Server to manage your build projects.
Prerequisites

Verify that you have installed and configured Visual Studio Team Foundation Server 2013 or 2015.
Procedure

1

Select Code Stream > Endpoints.

2

Click Add.

3

Select Team Foundation Server from the Endpoint Type drop-down menu.

4

Enter a Team Foundation Server endpoint name and an applicable description.

5

Enter the Team Foundation Server configuration details.
Option

Description

Team Foundation Server Instance
Name

Enter the Team Foundation Server instance name.

User Credentials

User name and password for the Team Foundation Server.

Domain Name

Domain name for the Team Foundation Server.

For example: qe-tfs-test

If the Team Foundation Server is not in a domain, you can use the Windows
server host name.
URL

Enter the host URL as protocol://host:port/tfs.
For example: http://192.10.121.12:8080/tfs or https://192.10.121.12:8080/tfs

Polling Interval

Frequency of polling by the external system to determine the progress update or
status.

TFS Server Version

Select the TFS Server version as 2013 or 2015.
You can accept the default setting or select Yes to enable this configuration. The
offline creation allows you to create the endpoint when the server is not
accessible.

6

When the endpoint is created, you can select Offline Creation to require a validation and certificate
acceptance.
The offline creation allows you to create the endpoint when the server is not accessible. You can
accept the default setting, or select Yes to enable this configuration.

7

Click Save.

What to do next

To use this endpoint in the release pipeline, you must create a provision task. See the Using vRealize
Code Stream guide.
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Register a Cloud Foundry Server Endpoint
You can register a Cloud Foundry server as an endpoint to deploy and manage life cycle of a cloud
application.
Prerequisites

You can enable operations and manage pipelines during an application delivery.
n

Verify that the Cloud Foundry server version is 255 or later.

Procedure

1

Select Code Stream > Endpoints.

2

Click Add.

3

Select Cloud Foundry from the Endpoint Type drop-down menu.

4

Enter a Cloud Foundry server endpoint name and an applicable description.
For example, in the description section you can add the release pipeline name that uses this Cloud
Foundry server endpoint.

5

6

Enter the Cloud Foundry server configuration details.
Option

Description

URL

Enter the API endpoint URL https://tapi.example.com.

User Credentials

User name and password for the Cloud Foundry server.

Polling Interval

Frequency of polling by the external system to determine the progress update or
status.

When the endpoint is created, you can select Offline Creation to require a validation and certificate
acceptance.
The offline creation allows you to create the endpoint when the server is not accessible. You can
accept the default setting, or select Yes to enable this configuration.

7

Click Save.

What to do next

To use this endpoint in the release pipeline, you must create a test task. See the Using vRealize Code
Stream guide.

Register a Bamboo Server Endpoint
You can run tests or other plans by using the Bamboo plug-in that allows you to use custom automation
and scripts. You can use the endpoint to invoke a Bamboo build plan during the modeling of a release
pipeline and execute the plan as part of the release pipeline.
You can use any Bamboo plan in the Bamboo server in the release pipeline with the endpoint enabled.
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Prerequisites
n

Verify that the Bamboo server version is 5.9.7 or later.

Procedure

1

Select Code Stream > Endpoints.

2

Click Add.

3

Select Bamboo from the Endpoint Type drop-down menu.

4

Enter a Bamboo server endpoint name and an applicable description.
For example, in the description section you can add the release pipeline name that uses this Bamboo
server endpoint.

5

6

Enter the Bamboo server configuration details.
Option

Description

URL

Enter the host URL as protocol://host:port. For example: http://10.112.68.76:8085

User Credentials

User name and password for the Bamboo server.

Request Retry Count

Number of times to retry the scheduled build request for the Bamboo server.

Polling Interval

Frequency of polling by the external system to determine the progress update or
status.

Retry Wait Time

Seconds to wait before retrying the build request for the Bamboo server.

When the endpoint is created, you can select Offline Creation to require a validation and certificate
acceptance.
The offline creation allows you to create the endpoint when the server is not accessible. You can
accept the default setting, or select Yes to enable this configuration.

7

Click Save.

What to do next

To use this endpoint in the release pipeline, you must create a test task. See the Using vRealize Code
Stream guide.

Register a Bugzilla Server Endpoint
You can register a Bugzilla server endpoint to generate and update Bugzilla tasks or bugs from a release
pipeline.
You can create a Bugzilla task or bug using a pipeline task. You update the assignee, change the status
of the issue, and add comments to the issue.
Prerequisites
n

Verify that the Bugzilla server version is 5.x or later.
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Procedure

1

Select Code Stream > Endpoints.

2

Click Add.

3

Select Bugzilla from the Endpoint Type drop-down menu.

4

Enter a Bugzilla server endpoint name and an applicable description.
For example, in the description section you can add the release pipeline name that uses this Bugzilla
server endpoint.

5

6

Enter the Bugzilla server configuration details.
Option

Description

URL

Enter the host URL as protocol://host:port. For example:
http://192.10.121.13:8080

User Credentials

User name and password for the Bugzilla server.

When the endpoint is created, you can select Offline Creation to require a validation and certificate
acceptance.
The offline creation allows you to create the endpoint when the server is not accessible. You can
accept the default setting, or select Yes to enable this configuration.

7

Click Save.

What to do next

To use this endpoint in the release pipeline, you must create a test task. See the Using vRealize Code
Stream guide.

Register a JIRA Server Endpoint
You can register a JIRA server endpoint to generate and update JIRA tasks or issues from a release
pipeline.
You can create a JIRA task or issue using a pipeline task.You update the assignee, change the status of
the issue, and add comments to the issue.
Prerequisites
n

Verify that the JIRA server version is 6.3 or later.

Procedure

1

Select Code Stream > Endpoints.

2

Click Add.

3

Select JIRA from the Endpoint Type drop-down menu.
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4

Enter a JIRA server endpoint name and an applicable description.
For example, in the description section you can add the release pipeline name that uses this JIRA
server endpoint.

5

6

Enter the JIRA server configuration details.
Option

Description

JIRA Endpoint URL

Enter the host URL as protocol://host:port.

User Credentials

User name and password for the JIRA server.

When the endpoint is created, you can select Offline Creation to require a validation and certificate
acceptance.
The offline creation allows you to create the endpoint when the server is not accessible. You can
accept the default setting, or select Yes to enable this configuration.

7

Click Save.

What to do next

To use this endpoint in the release pipeline, you must create a test task. See the Using vRealize Code
Stream guide.
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4

vRealize Code Stream troubleshooting provides procedures to resolve issues that you might encounter
when you install or configure vRealize Automation.
This chapter includes the following topics:
n

Default Log Locations

n

Create a Support Bundle for VMware vRealize Automation

n

Plug-ins Might Not Load

n

vRealize Automation Services Might Not Start

n

Blank Pages Might Appear When Using Internet Explorer 9 or 10 on Windows 7

n

Troubleshooting the vRealize Automation Appliance

n

Troubleshooting Log-In Errors

Default Log Locations
For information about a failed installation, consult the system and product log files.
The VMware vRealize Automation (vRA) content pack for vRealize Log Insight provides a consolidated
summary of log events in all the vRealize Automation components. For more information, see the vRA
6.1+ Log Insight Content Pack description on VMware Solution Exchange at
https://solutionexchange.vmware.com/store/products/vra-6-1-log-insight-content-pack#.VU0r3_PD-Ht

vRealize Automation Framework Logs
Log entries for vRealize Automation Frameworks are located in the following location.
Log

Default location

Framework Logs

/var/log/vmware

Create a Support Bundle for VMware vRealize Automation
A root user can create a support bundle in the vRealize Appliance management console. These bundles
can help VMware support staff to identify causes of issues you might encounter.
Use the following procedure to create a support bundle for vRealize Appliance.
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Procedure

1

Navigate to the vRealize Appliance management console by using its fully qualified domain name,
https://vrcs-va-hostname.domain.name:5480/.

2

Log in and go to Admin > Logs.

3

Click Create support bundle.

4

Click Download and save the file on your system.

You can use the support bundle to troubleshoot issues on your own or to send to your VMware support
representative.

Plug-ins Might Not Load
vRealize Code Stream might not be able to load a plug-in.
Problem

When vRealize Code Stream attempts to load a plug-in, the endpoint for the plug-in does not appear in
the drop down menu, and displays an error message.
Cause

The plug-in might fail to load when you install and configure the current version of vRealize Code Stream.
Solution

1

Establish an SSH connection to the virtual appliance.
For example: ssh root@VRCS_APPLIANCE

2

Check the status of the service with the following command:
service tekton-server status

3

If the status appears as stopped, run the service with the following command:
service tekton-server restart
If the endpoint still does not appear, contact Customer Support.

vRealize Automation Services Might Not Start
vRealize Code Stream might not be able to start if the vRealize Automation services fail to start.
Problem

When you attempt to start vRealize Code Stream, it might fail to start, and as a result display an error
message if the vRealize Automation services are not started.
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Cause

The service for vRealize Code Stream is named release-management-service in the CAFÉ appliance
that deploys the services for provisioning in vRealize Automation. After you install and configure the
current version of vRealize Code Stream, the services might not start. This problem might occur for a
number of reasons. As a result, a single solution cannot be provided. If the problem persists, contact
Customer Support.

Blank Pages Might Appear When Using Internet Explorer
9 or 10 on Windows 7
When you use Internet Explorer 9 or 10 on Windows 7, and compatibility mode is enabled, some pages
appear to have no content.
Problem

When using Internet Explorer 9 or 10 on Windows 7, the following pages have no content:
n

Default Tenant Folder on the Orchestrator page

n

Server Configuration on the Orchestrator page

Cause

The problem might be related to compatibility mode being enabled. You can disable compatibility mode
for Internet Explorer with the following steps.
Solution
Prerequisites

Ensure that the menu bar is displayed. If you are using Internet Explorer 9 or 10, press Alt to display
the Menu bar. Or, right-click the Address bar and select Menu bar.
Procedure

1

Select Tools > Compatibility View settings.

2

Deselect Display intranet sites in Compatibility View.

3

Click Close.

Troubleshooting the vRealize Automation Appliance
The troubleshooting topics for vRealize Automation appliances provide solutions to potential installationrelated problems that you might encounter when using your vRealize Automation appliances.

Encryption.key File has Incorrect Permissions
A system error can result when incorrect permissions are assigned to the Encryption.key file for a virtual
appliance.
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Problem

You log in to vRealize Appliance and the Tenants page is displayed. After the page has begun loading,
you see the message System Error.
Cause

The Encryption.key file has incorrect permissions or the group or owner user level is incorrectly assigned.
Solution
Prerequisites

Log in to the virtual appliance that displays the error.
Note If your virtual appliances are running under a load balancer, you must check each virtual
appliance.
Procedure

1

View the log file /var/log/vcac/catalina.out and search for the message Cannot write
to /etc/vcac/Encryption.key.

2

Go to the /etc/vcac/ directory and check the permissions and ownership for the Encryption.key
file. You should see a line similar to the following one:
-rw------- 1 vcac vcac 48 Dec 4 06:48 encryption.key

Read and write permission is required and the owner and group for the file must be vcac.
3

If the output you see is different, change the permissions or ownership of the file as needed.

What to do next

Log in to the Tenant page to verify that you can log in without error.

Troubleshooting Log-In Errors
The troubleshooting topics for log-in errors for vRealize Automation provide solutions to potential
installation-related problems that you might encounter when using vRealize Automation.

Cannot Log in to a Tenant or Tenant Identity Stores Disappear
Ninety days after deployment, you cannot log into a tenant or the identity store for a tenant disappears.
Problem
n

When you log in to a tenant, you see a blank page displayed with a Submit button in the upper lefthand corner.

n

You receive a System Exception error when accessing the tenant ID store configuration page.

n

The ID store configuration disappears.
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n

You cannot log in to a tenant by using an LDAP account.

n

The catalina.out log located in /var/log/vmware/vcac/ shows an error similar to the following:
12:40:49,190 [tomcat-http--34] [authentication] INFO
com.vmware.vim.sso.client.impl.SecurityTokenServiceImpl
$RequestResponseProcessor.handleFaultCondition:922 - Failed trying to retrieve
token: ns0:RequestFailed: Error occurred looking for solution user ::
Insufficient access YYYY-03-18 12:40:49,201 [tomcat-http--34] [authentication]
ERROR
com.vmware.vcac.platform.service.rest.resolver.ApplicationExceptionHandler.handle
UnexpectedException:820 - Failed trying to retrieve token: ns0:RequestFailed:
Error occurred looking for solution user :: Insufficient access
com.vmware.vim.sso.client.exception.InternalError: Failed trying to retrieve
token: ns0:RequestFailed: Error occurred looking for solution user ::
Insufficient access

Cause

The SSO internal tenant administrator password expires after 90 days by default. This issue is internal to
vRealize Automation and does not affect external, Active Directory identity stores.
It is a known issue that the vRealize Automation user interface does not provide notification that the
tenant administrator password is expiring. The workaround for this issue is to disable password expiration
for the tenant administrator account.
For step-by-step instructions to resolve this issue, see the VMware knowledge base article at
http://kb.vmware.com/kb/2075011.
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