Information about the Log Insight Agents instances does not appear on the Agents page of the Management UI.
Problem
After you install the Log Insight Agents you do not see the Log Insight Agents in the Agents page of the Management UI.
Cause
The most common causes are network connectivity problems or incorrect configuration of the Log Insight Agents in the liagent.ini file.
Solution
- Verify that the Windows or Linux system that the Log Insight Agents are installed on has connectivity to the vRealize Log Insight server.
- Verify that the Log Insight Agents use the cfapi protocol.
When using the syslog protocol the UI does not show
Log Insight Windows Agents.
- View the contents of the Log Insight Agents log files located in the following directories .
- Windows - %ProgramData%\VMware\Log Insight Agent\log
- Linux - /var/log/loginsight-agent/
Look for log messages that contain the phrases
Config transport error: Couldn't resolve host name and
Resolver failed. No such host is known.
- Verify that the liagent.ini contains the correct configuration for the target vRealize Log Insight server. See Set Target Log Insight Server of the Log Insight Windows Agent and Set Target Log Insight Server of the Log Insight Linux Agent.