A vRealize Log Insight primary or worker node might run out of disk space if you are using a small virtual disk, and archiving is not activated.

Problem

vRealize Log Insight runs out of disk space if the rate of incoming logs exceeds 3 percent of the storage space per minute, or when vRealize Log Insight cannot delete the oldest buckets from the storage.

Cause

In normal situations, vRealize Log Insight never runs out of disk because every minute it checks if the free space is less than 3 percent. If the free space on the vRealize Log Insight virtual appliance drops below 3 percent, old data buckets are retired.

If archiving is activated, vRealize Log Insight archives the bucket before marking it as archived and retiring in future. If the free space is filled before the old bucket is archived and retired, vRealize Log Insight runs out of disk.

Solution

Verify whether the data archival location is available and has enough free space. See Data Archiving.
Note: If none of the solutions are applicable, contact customer support.