An incorrect configuration can prevent the vRealize Log Insight agents from forwarding logs to the vRealize Log Insight server. If a flat file collection channel is not configured correctly, you may see messages such as “Invalid settings were obtained for channel 'CHANNEL_NAME'. Channel 'CHANNEL_NAME' will stay dormant until properly configured.”
Problem
The vRealize Log Insight agents instances appears on the page but no logs appear in Interactive Analytics page from the vRealize Log Insight agents host names. The flat file collection channel is not configured correctly.
Cause
Incorrect configuration can prevent the vRealize Log Insight agents from forwarding logs to the vRealize Log Insight server.
Solution
- Define a valid collection channel. Verify whether or not the flat file collection channel is configured correctly. See Configuring vRealize Log Insight Agents.
- For the vRealize Log Insight Windows agent, try the following.
- If Windows channels are enabled, view the contents of the vRealize Log Insight Windows agent log files located at %ProgramData%\VMware\Log Insight Agent\log. Look for log messages related to channel configuration that contain the phrases Subscribed to channel CHANNEL_NAME. Typically-used channels are Application, System, and Security.
- If a channel is not configured correctly, you might see log messages similar to Could not subscribe to channel CHANNEL_NAME events. Error Code: 15007. The specified channel could not be found. Check channel configuration. You might see an error code number other than 15007.
- If a flat file collection channel is not configured correctly, you might see messages like Invalid settings were obtained for channel 'CHANNEL_NAME'. Channel 'CHANNEL_NAME' will stay dormant until properly configured
- For both vRealize Log Insight Windows agent and vRealize Log Insight Linux agent, try the following.
- If no flat file collection channel is configured, you might see messages similar to Cannot find section 'filelog' in the configuration. The flat file log collector will stay dormant until properly configured
The contents of the vRealize Log Insight agents log files are located in the following directories.
- Windows - %ProgramData%\VMware\Log Insight Agent\log
- Linux - /var/log/loginsight-agent/
- If no flat file collection channel is configured, you might see messages similar to Cannot find section 'filelog' in the configuration. The flat file log collector will stay dormant until properly configured
What to do next
For more information about configuring the vRealize Log Insight agents see Configure the Log Insight Windows Agent and Configure the Log Insight Linux Agent.