If the time settings between vRealize Application Remote Collector and vRealize Operations Manager are not synchronized, you might face agent installation and metric collection issues. Eventually, you might not see any metrics in the vRealize Operations Manager dashboards.

Problem

You might notice the following issues in vRealize Operations Manager:
  • You cannot add vRealize Application Remote Collector to vRealize Operations Manager
  • You cannot install an agent in the Windows and Linux target VMs.

Cause

Time synchronization is a prerequisite of the TLS/SSO communication between client and server.

If the vRealize Operations Manager and vRealize Application Remote Collector are not time synchronized, the test connection fails while configuring vRealize Application Remote Collector in vRealize Operations Manager.

If the Windows and Linux target VMs are not time synchronized with vRealize Operations Manager, communication between vRealize Application Remote Collector and agents will break after installing the agents. Hence monitored metrics are not sent to vRealize Operations Manager. Alternatively, stop and restart the agent to resolve this issue.

Solution

  1. Check the vRealize Operations Manager support bundle in the following path: COLLECTOR/adapters/APPOSUCPAdapter/ for errors.
  2. Check the vRealize Application Remote Collector support bundle, ucpapi.log, for errors.
  3. Ensure time synchronization between vRealize Application Remote Collector, vRealize Operations Manager and the Windows and Linux target VMs.
  4. To start and restart the agent, see Additional Operations from the Manage Agents Tab.