vRealize Orchestrator 7.3 supports in-place upgrade from versions 6.0.x, 7.0, 7.1, and 7.2. For Orchestrator 5.5.x, you must upgrade to version 6.0.x first.