Puede que reciba un error durante el proceso de recuperación si el usuario de la solución Site Recovery Manager carece de permisos para realizar una personalización de IP u operaciones de llamada al sistema operativo en el invitado.

Problema

Si el usuario de la solución Site Recovery Manager carece de los permisos adecuados para el sistema operativo invitado de la máquina virtual recuperada, podría recibir uno de los siguientes mensajes de error durante el proceso de recuperación.
GuestPermissionDenied
CannotAccessFile

Causa

El problema aparece si el usuario de la solución Site Recovery Manager está asignado a un usuario de sistema operativo invitado que no tiene acceso a un archivo en el sistema operativo invitado o carece de permisos para ejecutar comandos.

Solución

  1. Si utiliza Site Recovery Manager para configurar las asignaciones de usuario invitado, asegúrese de que el usuario de sistema operativo invitado que ejecuta el servicio de VMware Tools tenga acceso al archivo o tenga permiso para ejecutar comandos.
    Para obtener más información sobre cómo activar o desactivar la configuración automática de las asignaciones de usuario invitado, consulte Cambiar la configuración de la recuperación.
  2. (opcional) Si configura manualmente las asignaciones de usuario invitado, asigne el usuario de la solución Site Recovery Manager local en el sitio de recuperación al usuario de sistema operativo invitado con los permisos adecuados.
  3. Vuelva a ejecutar el plan de recuperación.