Los VMware Aria Operations for Logs Agents rechazan el certificado autofirmado.
Problema
Un agente de VMware Aria Operations for Logs rechaza el certificado autofirmado y no puede establecer una conexión con el servidor.
Nota: Si experimenta problemas de conexión con el agente, puede generar registros detallados y consultarlos. Para ello, cambie el nivel de depuración del agente a 1. Para obtener más información, consulte
Definir el nivel de detalles de registro en los VMware Aria Operations for Logs Agents.
Causa
Los mensajes que aparecen en el registro del agente incluyen motivos específicos.
Message (Mensaje) | Causa |
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Rechazo del certificado autofirmado del mismo nivel. La clave pública no coincide con la clave del certificado almacenada previamente. |
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Rechazo del certificado autofirmado del mismo nivel. Tiene un certificado recibido previamente que fue firmado por una CA de confianza. | Hay un certificado firmado por una CA almacenado en el agente. |
Solución
- ♦ Verifique si su nombre de host de destino es una instancia de VMware Aria Operations for Logs de confianza y luego elimine manualmente el certificado previo del agente de VMware Aria Operations for Logs, directorio cert.
- Para VMware Aria Operations for Logs Windows Agent, vaya a C:\ProgramData\VMware\Log Insight Agent\cert.
- Para VMware Aria Operations for Logs Linux Agent, vaya a /var/lib/loginsight-agent/cert.
Nota: Algunas plataformas pueden usar rutas de acceso no estándar para almacenar certificados de confianza. Los VMware Aria Operations for Logs Agents tienen una opción que permite configurar la ruta de acceso al almacén de certificados de confianza estableciendo el parámetro de configuración ssl_ca_path=<fullpath>. Reemplace<fullpath>
por la ruta de acceso al archivo del paquete de certificados raíz de confianza. Consulte Configurar los parámetros de SSL.