Si VMware Cloud Director celdas restringen el acceso saliente a AWS S3, al suscribirse al catálogo de aplicaciones Bitnami en VMware Marketplace se produce un error y se excede el tiempo de espera de las tareas de sincronización de plantillas de vApp.

Problema

Tiempo de espera excedido en el intento de importación de Bitnami aplicaciones desde VMware Marketplace, con un 1% de la tarea completada.

Además, los registros de VMware Cloud Director informan de que no se puede acceder al nombre de host *.s3.us-west-2.amazonws.com.

Para comprobar que el acceso saliente está restringido, ejecute el siguiente comando desde la celda de la máquina VMware Cloud Director:
curl -i -k -v https://s3.us-west-2.amazonaws.com
Si el acceso saliente está restringido, el sistema devuelve un mensaje Estado 307.

Causa

Las aplicaciones de Bitnami se almacenan en AWS S3. Si VMware Cloud Director no puede acceder a los catálogos de Bitnami, no es posible importar ni sincronizar aplicaciones.

Solución

Para evitar estos problemas, permita el acceso saliente a AWS S3 desde la celda de VMware Cloud Director. Si VMware Cloud Director celdas permiten el acceso saliente a través de un proxy HTTP, asegúrese de que el host proxy esté configurado en la máquina de la celda.