Para preparar la base de datos para actualizar a la versión 2.1.1, elimine la restricción conname de la tabla bucket_info.

Requisitos previos

  • Compruebe que la versión anterior de VMware Cloud Director Object Storage Extension esté desinstalada.
  • Compruebe que actualizó la base de datos de PostgreSQL a la versión 9.5 o una versión posterior.
  • Compruebe que hizo una copia de seguridad de la base de datos.

Procedimiento

  1. Inicie sesión en la base de datos PostgreSQL como administrador de base de datos.
  2. Recupere el OID de la restricción conname para la tabla bucket_info.
    SELECT conname
    FROM pg_constraint
    WHERE conrelid =
        (SELECT oid
        FROM pg_class
        WHERE relname like 'bucket_info');
    El sistema devuelve la cadena de OID. Por ejemplo, ukb9c15fhp50s53gs8pntjaq5qt. Copie el OID para poder usarlo en el siguiente paso.
  3. Elimine las restricciones de la tabla bucket_info.
    ALTER TABLE bucket_info
           DROP CONSTRAINT IF EXISTS {OID};
  4. (opcional) Elimine las tablas que no se utilizan en VMware Cloud Director Object Storage Extension 2.1.1.
    DROP TABLE IF EXISTS um_storage_can_id;
     
    DROP TABLE IF EXISTS um_storage_user_id;
     
    DROP TABLE IF EXISTS pwc_object_info;

Resultados

La base de datos PostgreSQL está preparada para la actualización a VMware Cloud Director Object Storage Extension 2.1.1.