View Composer necesita una base de datos SQL para almacenar datos. La base de datos debe residir o estar disponible en el host del servidor de View Composer. Puede configurar de forma opcional una base de datos de eventos para registrar información desde el servidor de conexión de View sobre los eventos de View.

Si una instancia del servidor de la base de datos ya existe para vCenter Server, View Composer puede usar esa instancia existente si es una de las versiones que aparece en 1. Por ejemplo, View Composer puede usar la instancia de Microsoft SQL Server proporcionada con vCenter Server. Si no existe ninguna instancia del servidor de la base de datos, debe instalar una.

View Composer admite un subconjunto de servidores de la base de datos que vCenter Server admite. Si ya utiliza vCenter Server con un servidor de la base de datos que View Composer no admita, continúe usando el servidor de la base de datos para vCenter Server e instale un servidor de la base de datos independiente para usar View Composer.

Importante:

Si crea la base de datos de View Composer en la misma instancia de SQL Server que vCenter Server, no sobrescriba la base de datos de vCenter Server.

La siguiente tabla muestra los servidores de la base de datos y las versiones de la fecha de publicación de este documento. Para la mayor parte de la información actualizada sobre las bases de datos admitidas, consulte Matrices de interoperabilidad de productos de VMware en http://www.vmware.com/resources/compatibility/sim/interop_matrix.php. En el apartado de la interoperabilidad entre la base de datos y la solución, después de seleccionar el producto y la versión (en el paso para agregar una base de datos), si desea consultar una lista de todas las bases de datos compatibles, seleccione Cualquiera y haga clic en Agregar.

Tabla 1. Servidores de base de datos que View Composer y las bases de datos de eventos admiten

Base de datos

Versiones/paquetes de servicio

Ediciones

Microsoft SQL Server 2014

(32 y 64 bits)

Sin SP, SP1

Standard

Enterprise

Microsoft SQL Server 2012

(32 y 64 bits)

SP2

Express

Standard

Enterprise

Microsoft SQL Server 2008 R2

(32 y 64 bits)

SP2, SP3

Express

Standard

Enterprise

Datacenter

Oracle 12c

Versión 1 (cualquier versión hasta 12.1.0.2)

Standard One

Standard

Enterprise

Nota:

Las siguientes versiones ya no son compatibles: Microsoft SQL Server 2008 SP4 y Oracle 11g Release 2 (11.2.0.04).