El proceso de actualización de View Composer tiene limitaciones y requisitos especiales.

Para ejecutar el instalador de View Composer, debe ser un usuario de dominio con privilegios de administrador en el sistema.

Requisitos relacionados con la seguridad

  • View Composer requiere un certificado SSL firmado por una CA (entidad de certificación). Si piensa reemplazar un certificado existente o el certificado autofirmado y predeterminado por uno nuevo después de instalar View Composer, debe importar el nuevo certificado y ejecutar la utilidad SviConfig ReplaceCertificate para enlazar el nuevo certificado al puerto que usa View Composer.

    Si instala vCenter Server y View Composer en el mismo equipo Windows Server, pueden usar el mismo certificado SSL, pero debe configurar el certificado de forma independiente para cada componente.

    Para obtener una información completa sobre los requisitos del certificado de seguridad, consulte "Configurar certificados SSL en View Server", disponible en el documento Instalación de View.

  • Los certificados para vCenter Server, View Composer, y View Servers deben incluir las listas de revocación de certificados (CRL). Para obtener más información, consulte "Configurar la comprobación de la revocación de los certificados del servidor" en la guía Instalación de View.

  • Verifique que ninguna aplicación que se ejecute en el equipo de View Composer use las bibliotecas SSL de Windows que necesiten la versión 2 de SSL (SSLv2) proporcionada a través del paquete de seguridad del canal seguro de Microsoft (Schannel). El instalador de View Composer deshabilita SSLv2 en Schannel de Microsoft. Estas restricciones no afectan a las aplicaciones como Tomcat, que usa Java SSL, o Apache, que usa OpenSSL. SSLv3, TLSv1.0 y RC4 también están deshabilitados de forma predeterminada. Para obtener más información, consulte "Cifrados y protocolos anteriores deshabilitados en View" en el documento de Seguridad de View.

  • Para mejorar la seguridad de View Composer, deshabilite los conjuntos de claves de cifrado débiles en el equipo Windows Server en el que esté instalado el servicio de View Composer. Consulte la sección sobre cómo deshabilitar los conjuntos de claves de cifrado débiles en el servidor de View Composer en el documento Instalación de View.

  • Es posible que necesite realizar cambios en la configuración del protocolo para que siga siendo compatible con vSphere. Si es posible, aplique revisiones a ESXi y a vCenter Server para que admitan TLSv1.1 y TLSv1.2 antes de actualizar View Composer. Si no puede aplicar las revisiones, vuelva a habilitar TLSv1.0 en View Composer antes de la actualización. Si desea obtener más información, consulte Habilitar TLSv1.0 en vCenter y conexiones ESXi desde View Composer.

  • A partir de la versión 7.0.3 de Horizon 7, puede habilitar la autenticación implícita de acceso para View Composer para mejorar la seguridad. Si desea obtener más información, consulte Habilitar la autenticación implícita de acceso para View Composer.