La instancia del servidor de conexión que tengan la tarjeta inteligente conectada no pueden realizar comprobaciones de revocación del certificado TLS a menos que configurara la comprobación de revocación del certificado de la tarjeta inteligente.

Problema

La comprobación de revocación de certificados puede fallar si la organización utiliza un servidor proxy para acceder a Internet o si la instancia del servidor de conexión no puede alcanzar los servidores que ofrecen la comprobación de revocación debido al firewall u otros controles.

Importante: Asegúrese de que el archivo CRL esté actualizado.

Causa

VMware Horizon admite la comprobación de revocación de certificados con listas de revocación de certificados (CRL) y con el protocolo de estado de certificado en línea (OCSP). Una CRL es una lista de certificados revocados publicada por la autoridad de certificación (CA) que los emitió. OCSP es un protocolo de validación de certificados que se utiliza para obtener el estado de revocación de un certificado X.509. Es necesario que se pueda acceder a la CA desde el host del servidor de conexión. Este problema puede ocurrir si configuró la comprobación de revocación de los certificados de tarjetas inteligentes. Consulte Uso de la comprobación de revocación de certificados de tarjeta inteligente.

Solución

  1. Cree su propio procedimiento (manual) para descargar y actualizar la CRL en una ruta de VMware Horizon Server desde el sitio web de la CA que utiliza.
  2. Cree o edite el archivo locked.properties en la carpeta de configuración de la puerta de enlace TLS/SSL en el host del servidor de conexión.
    Por ejemplo: directorio_de_instalación\VMware\VMware View\Server\SSLgateway\conf\locked.properties
  3. Agregue las propiedades enableRevocationChecking y crlLocation en el archivo locked.properties de la ruta local donde la CRL está almacenada.
  4. Reinicie el servicio del servidor de conexión para que se apliquen los cambios.