Los problemas de los certificados en una instancia de Connection Server no le permiten conectarse a Horizon Console o hacen que se muestre un indicador de estado rojo en un servidor.

Problema

No puede conectarse a Horizon Console en la instancia del servidor de conexión que tiene el problema. Cuando se conecta a Horizon Console en otra instancia del servidor de conexión que se encuentra en el mismo pod, puede ver que el indicador de estado del panel de control de la instancia del servidor de conexión con el problema se encuentra en rojo.

En la otra instancia del servidor de conexión, haga clic en el indicador de estado rojo que muestra Certificado SSL: no válido y Estado: (vacío), indicando que no se encuentra un certificado válido. El archivo de registro VMware Horizon 8 contiene una entrada del tipo ERROR con el siguiente mensaje: No existe ningún certificado aplicable en el almacén de claves.

Los datos de registro de VMware Horizon 8 están en <Letra de la unidad>:\ProgramData\VMware\log\ConnectionServer en la instancia de Connection Server.
Nota: Esta ruta de archivo es un vínculo simbólico que redirige a la ubicación real de los archivos de registro, que es <Letra de la unidad>:\ProgramData\VMware\VDM\logs.

Causa

Es posible que un certificado no se instale correctamente en VMware Horizon 8 Server por alguna de las siguientes razones:

  • El certificado no está en la carpeta Personal en el almacén de certificados del equipo local Windows.
  • El almacén de certificados no tiene ninguna clave privada del certificado.
  • El nombre descriptivo del certificado no es vdm.
  • El certificado se generó desde una plantilla de certificados v3 para Windows Server 2008 o un servidor posterior. VMware Horizon 8 no puede detectar una clave privada, pero si usa el complemento Certificados para examinar el almacén de certificados de Windows, el almacén indica que existe una clave privada.

Solución