NSX Container Plug-in (NCP) tiene los siguientes requisitos de compatibilidad para un entorno de Kubernetes y un entorno de Pivotal Cloud Foundry (PCF).

Tabla 1. Requisitos de compatibilidad para un entorno de Kubernetes
Productos de software Versión
NSX-T Data Center 2.3, 2.4
Hipervisor para las máquinas virtuales de los hosts del contenedor
Sistema operativo del host del contenedor
  • RHEL 7.5, 7.6
  • Ubuntu 16.04
  • CentOS 7.4, 7.5
Orquestador del contenedor Kubernetes 1.12, 1.13
Open vSwitch del host del contenedor 2.9.1 (se incluye con NSX-T Data Center 2.3.x), 2.10.2 (se incluye con NSX-T Data Center 2.4.0)
Tabla 2. Requisitos de compatibilidad para un entorno de Cloud Foundry
Productos de software Versión
Hipervisor para las máquinas virtuales de los hosts del contenedor
Orquestador del contenedor
  • Pivotal Application Service 2.3.x y Pivotal Operations Manager 2.3.x
  • Pivotal Application Service 2.4.x (excepto 2.4.0) y Pivotal Operations Manager 2.4.x (excepto 2.4.0)