Después de configurar NSX-T Data Center, complete el procedimiento de configuración en Arista CloudVision eXchange (CVX) para permitir que CVX interactúe con NSX-T Data Center.

Requisitos previos

NSX-T Data Center registró CVX como punto de implementación.

Procedimiento

  1. Inicie sesión en NSX Manager como usuario raíz y ejecute el siguiente comando para crear una huella digital que permita que CVX se comunique con NSX Manager:
    openssl s_client -connect <IP address of nsx-manager>:443 | openssl x509 -pubkey -noout | openssl rsa -pubin -outform der | openssl dgst -sha256 -binary | openssl base64
    Resultados de muestra:
    depth=0 C = US, ST = CA, L = Palo Alto, O = VMware Inc., OU = NSX, CN = nsx-mgr
    verify error:num=18:self signed certificate
    verify return:1
    depth=0 C = US, ST = CA, L = Palo Alto, O = VMware Inc., OU = NSX, CN = nsx-mgr
    verify return:1
    writing RSA key
    S+zwADluzeNf+dnffDpYvgs4YrS6QBgyeDry40bPgms=
  2. Ejecute el siguiente comando desde la CLI de CVX:
    cvx
    no shutdown
    service pcs
    no shutdown
    controller <IP address of nsx-manager>
    username <NSX administrator user name>
    password <NSX administrator password>
    enforcement-point cvx-default-ep
    pinned-public-key <thumbprint for CVX to communicate with NSX
    				  Manager>
    notification-id <notification ID created while registering CVX with NSX>
    end
    
  3. Ejecute el siguiente comando desde la CLI de CVX para comprobar la configuración:
    show running-config
    Resultado de muestra:
    cvx
          no shutdown
       source-interface Management1
       !
       service hsc
          no shutdown
    
       !
       service pcs
          no shutdown
          controller 192.168.2.80
          username admin
          password 7 046D26110E33491F482F2800131909556B
          enforcement-point cvx-default-ep
          pinned-public-key sha256//S+zwADluzeNf+dnffDpYvgs4YrS6QBgyeDry40bPgms=
          notification-id a0286cb6-de4d-41de-99a0-294465345b80
  4. Configure tag en la interfaz Ethernet del conmutador físico que se conecta al servidor físico. Ejecute los siguientes comandos en el conmutador físico administrado por CVX.
    configure terminal
    interface ethernet 4
    tag phy_app_server
    end
    copy running-config startup-config
    Copy completed successfully.
  5. Ejecute el siguiente comando para comprobar la configuración de etiquetas del conmutador:
    show running-config section tag
    Resultados de muestra:
    interface Ethernet4
       description connected-to-7150s-3
       switchport trunk allowed vlan 1-4093
       switchport mode trunk
       tag sx4_app_server
    

    Las direcciones IP que se obtienen en las interfaces etiquetadas mediante ARP se comparten con NSX-T Data Center.

  6. Inicie sesión en NSX Manager para crear y publicar reglas de firewall para las cargas de trabajo físicas administradas por CVX. Consulte Seguridad para obtener más información sobre la creación de reglas. Por ejemplo:

    Las directivas y reglas de NSX-T Data Center publicadas en NSX-T Data Center aparecen como ACL dinámicas en el conmutador físico administrado por CVX.

    Para obtener más información, consulte Configuración de HA de CVX, Configuración de IP virtual de HA de CVX y Configuración de Mlag del conmutador físico