Omita esta sección si no hay paquetes de OVS en el host de Ubuntu. Si ya hay paquetes de OVS en el host de Ubuntu, debe eliminar los paquetes de OVS existentes e instalar los paquetes de OVS compatibles con NSX-T, o bien actualizar los paquetes de OVS existentes a paquetes compatibles con NSX-T.

La versión Open vSwitch compatible es la 2.13.1.xxxxxx.

Procedimiento

  1. Compruebe la versión actual de la instancia de Open vSwitch instalada en el host.
    ovs-vswitchd --version
    Importante: Si los paquetes de Open vSwitch existentes ejecutan la versión más reciente o una anterior, debe sustituir los paquetes de Open vSwitch existentes por la versión compatible.
  2. Compruebe si hay paquetes de Open vSwitch en el host.
    dpkg -l | grep openvswitch
  3. Desplácese hasta los paquetes de Open vSwitch requeridos por NSX-T Data Center.
    1. Inicie sesión en el host como administrador.
    2. Descargue y copie el archivo nsx-lcp en el directorio /tmp.
    3. Descomprima el paquete.
      tar -zxvf nsx-lcp-<release>-ubuntu-xenial_amd64.tar.gz O bien
      tar -zxvf nsx-lcp-<version>-linux64-bionic_amd64.tar.gz
    4. Desplácese hasta el directorio del paquete.
      cd nsx-lcp-xenial_amd64 O bien
      cd nsx-lcp-bionic_amd64
  4. Compruebe los paquetes de Open vSwitch en el paquete nsx-lcp.

    ls | grep openvswitch

  5. Elimine los paquetes de Open vSwitch.
    dpkg --purge <package1> <package2> <package3>….
  6. Si los paquetes de Open vSwitch se eliminan correctamente en el host, continúe con la interfaz de usuario de NSX Manager para preparar el host de KVM como nodo de transporte. Si no se pueden eliminar los paquetes de Open vSwitch, continúe con el paso siguiente.
  7. Si no se pueden eliminar los paquetes, actualice la versión del paquete de Open vSwitch existente con una compatible.

    dpkg -iRB *openvswitch*.deb