Si el estado del clúster de contenedores de Antrea es inactivo, siga los pasos descritos en esta documentación para determinar la causa del problema y recuperarse de él, o para recopilar el paquete de soporte.

Problema

El nodo de plano de control del clúster está inactivo. El clúster de contenedores de Antrea está desconectado del plano de control central (CCP).

Causa

En la interfaz de usuario de NSX Manager, vaya a Sistema > Tejido > Nodos > Clústeres de contenedores > Antrea. Si es necesario. filtre la lista de clústeres en la página Antrea con el campo Identificador externo.

Haga clic en la columna Estado del clúster con problemas. Si todos los componentes están inactivos, las posibles causas son las siguientes:
  • Se eliminó el clúster de Kubernetes.
  • Problema de conectividad de red con el CCP.
  • Los adaptadores se bloquean o se eliminan por algún motivo.
  • El certificado de cliente de los adaptadores no es correcto.
  • La versión de los adaptadores no es compatible con el CCP.

Si solo Adaptador del plano de control central está inactivo, es posible que el adaptador CCP esté bloqueado.

Solución

  1. Si se eliminó el clúster de Kubernetes, limpie los datos de registro e inventario residuales en NSX. Consulte Eliminar un clúster de contenedores de Antrea del inventario de NSX-T usando la línea de comandos.
  2. Obtenga el acceso de kubectl y kubeconfig para el clúster de contenedores. Utilice kubectl para recuperar el nombre del nodo en el que se esté ejecutando el pod de interoperabilidad. Inicie una sesión de SSH en el nodo y utilice los comandos curl o nc para conectarse a cada IP de NSX Manager en los puertos 1234 y 1235. Si no se puede establecer la conexión, se trata de un problema de conectividad de red con el CCP.
    Ejemplo del comando curl:

    Asegúrese de reemplazar IP-NSX-Manager por la dirección IP de NSX Manager en su entorno.

    curl -v NSX-Manager-IP:1235
    
    Trying NSX-Manager-IP... 
    Connected to NSX-Manager-IP (NSX-Manager-IP) port 1235 (#0) 
    ... 
    Empty reply from server 
    Connection #0 to host NSX-Manager-IP left intact 
    curl: (52) Empty reply from server

    Ejemplo del comando nc:

    nc -v NSX-Manager-IP 1235 < /dev/null
    
    Ncat: Version 7.50 (https://nmap.org/ncat)
    Ncat: Connected to NSX-Manager-IP:1235.
    Ncat: 0 bytes sent, 0 bytes received in 0.37 seconds.
  3. Utilice kubectl para comprobar si todos los contenedores del pod de interoperabilidad en el espacio de nombres de vmware-system-antrea estén activos.
    Si algún contenedor está inactivo, utilice kubectl para obtener los registros de los contenedores bloqueados y compruebe el mensaje de error. Este paso puede ayudarle a identificar el error debido a cualquiera de estos motivos:
    • Los adaptadores se bloquean o se eliminan por algún motivo.
    • El adaptador CCP se bloqueó.
    Ejemplo del comando kubectl para obtener el pod de interoperabilidad:
    kubectl get pod -o wide -l app=antrea-interworking -n vmware-system-antrea

    Anote el nombre del pod de interoperabilidad.

    Ejemplo del comando kubectl para obtener el estado detallado del pod de interoperabilidad:

    Asegúrese de reemplazar nombre-pod por el nombre de pod real.

    kubectl get pod -o yaml pod-name -n vmware-system-antrea

    Ejemplo del comando kubectl para obtener registros de contenedor:

    Asegúrese de reemplazar nombre-pod por el nombre de pod real.

    kubectl logs pod-name -c mp-adapter -n vmware-system-antrea > mp-adapter.log
    kubectl logs pod-name -c ccp-adapter -n vmware-system-antrea > ccp-adapter.log
    kubectl logs pod-name -c tn-proxy -n vmware-system-antrea > tn-proxy.log
    kubectl logs pod-name -c election-runner -n vmware-system-antrea > election-runner.log

    Si falta el espacio de nombres de vmware-system-antrea o el pod de interoperabilidad, es posible que los adaptadores se hayan eliminado del clúster de Kubernetes sin ejecutar los pasos de cancelación del registro. Puede limpiar el inventario y los datos de registro residuales del sistema y, a continuación, volver a registrar el clúster de Kubernetes. El identificador del clúster será diferente después de volver a registrar el clúster. Si hay alguna directiva de Antrea aplicada al clúster, debe volver a aplicar la directiva después de volver a registrar el clúster.

    Para obtener instrucciones sobre cómo limpiar los datos de registro residuales, consulte Eliminar un clúster de contenedores de Antrea del inventario de NSX-T usando la línea de comandos.

    Para obtener instrucciones sobre cómo registrar un clúster de contenedores de Antrea en NSX, consulte Registrar un clúster de contenedores de Antrea en NSX-T Data Center.

  4. Utilice kubectl para obtener registros del contenedor de nsx-proxy del pod de interoperabilidad y compruebe los mensajes de error.
    Este paso puede ayudarle a identificar el error debido a cualquiera de estos motivos:
    • El certificado de cliente de los adaptadores no es correcto.
    • La versión de los adaptadores no es compatible con el CCP.

    Para ver comandos de ejemplo, consulte el paso 3.

  5. Si Adaptador del plano de administración está activo, utilice la función de paquete de soporte de NSX para recopilar archivos de registro para el clúster de contenedores.