Se produjo un error en la comprobación previa de sincronización de las herramientas de Kubernetes.

Problema

El sistema valida las versiones de las herramientas de Kubernetes utilizadas en NSX Manager y en el clúster de Kubernetes ascendente o TKC que especificó en un paso anterior de preparación de la implementación.

Causa

La causa del error de comprobación previa puede ser uno de los siguientes motivos.

  • La diferencia entre el número de versión secundaria de las herramientas de Kubernetes en el dispositivo de NSX Manager y en el clúster de Kubernetes ascendente o TKC es superior a uno. Por ejemplo, si la versión instalada en el dispositivo de NSX Manager es la 1.18 y el clúster de Kubernetes ascendente o TKC utiliza la versión 1.19, se superará la comprobación previa. Sin embargo, si uno de ellos utiliza la versión 1.18 y el otro la 1.20, se producirá un error en la comprobación previa.

  • Si los dispositivos de NSX Manager no tienen instalada la misma versión de las herramientas de Kubernetes, se producirá un error en la comprobación previa.

Solución

  1. Actualice la versión de las herramientas de Kubernetes instalada en su dispositivo de NSX Manager descargando el paquete de herramientas de Kubernetes proporcionado en el sitio de descarga de productos de VMware en https://customerconnect.vmware.com/downloads/details?downloadGroup=NSX-INTLG-200&productId=931&rPId=64770.

    Los archivos binarios de las herramientas de Kubernetes se proporcionan a partir de NSX Intelligence 3.2.

  2. Cargue los archivos binarios de las herramientas de Kubernetes en el dispositivo de NSX Manager.

    Al cargar la versión actualizada en NSX Manager se actualizará el resto de las máquinas virtuales de NSX Manager.