Notas de la versión 10.1.5 de VMware Tools

|

Actualizado el: 27 de marzo de 2017

VMware Tools | 23 de febrero de 2017 | Compilación 5055683

Compruebe si existen actualizaciones adicionales a las notas de la versión.

Contenido de las Notas de la versión

Estas notas de la versión cubren los temas siguientes:

Novedades

VMware Tools es un conjunto de utilidades que incrementan el rendimiento del sistema operativo invitado de la máquina virtual y mejoran la administración de la máquina virtual.

  • Compatibilidad de VMware Tools con sistemas operativos invitados en la versión 10.1.5
    • windows.iso admite Windows Vista y versiones posteriores.
    • linux.iso admite sistemas operativos invitados Linux, Red Hat Enterprise Linux (RHEL) y versiones posteriores, SUSE Linux Enterprise Server (SLES) 11 y versiones posteriores, Ubuntu 10.04 y versiones posteriores. También admite otras distribuciones con glibc 2.5 y versiones posteriores.
    • darwin.iso admite la versión de Mac OS X 10.11 y versiones posteriores.
    • freebsd.iso admite las versiones de FreeBSD.
    • solaris.iso admite las versiones de Solaris.
  • Controladores y certificaciones: Controlador de gráficos Modelo de controladores de pantalla de Windows firmados (WDDM) 8.15.1.50 para VMware Tools 10.1.5. Para obtener más información sobre los controladores, consulte Controladores invitados de Windows instalados por VMware Tools
  • Problemas resueltos: Esta versión de VMware Tools 10.1.5 soluciona los problemas que se han documentado en la sección Problemas resueltos.

Versiones anteriores de VMware Tools

Notas de la versión 10.1.0 de VMware Tools

Para las versiones anteriores de VMware Tools 10.0.0, consulte la página Documentación de VMware Tools.

Antes de comenzar

Las imágenes ISO de VMware Tools se congelan al final de la vida de los sistemas operativos invitados. Algunas imágenes ISO no se envían con ESXi en el VIB tools-light. Para obtener más información, consulte la página Documentación de VMware Tools. Todas las imágenes ISO de VMware Tools se pueden descargar en http://my.vmware.com.

Es posible descargar los archivos ejecutables (.exe) instaladores de 32 y 64 bits de VMware Tools para Windows. Estos archivos se proporcionan para facilitar el acceso y la instalación de VMware Tools en los sistemas operativos invitados Windows.

Nota importante sobre la actualización a 3b de ESXi 5.5 o a versiones posteriores

Para ver la resolución sobre las incompatibilidades y las directrices generales al actualizar los hosts ESXi a la actualización 3b de ESXi 5.5 o a la actualización 1 de ESXi 6.0 (o posteriores), utilizando versiones anteriores de Horizon View Agent, consulte estos artículos de la base de conocimientos:

Internacionalización

VMware Tools 10.1.5 está disponible en los siguientes idiomas:

  • Inglés
  • Francés
  • Alemán
  • Español
  • Italiano
  • Japonés
  • Coreano
  • Chino simplificado
  • Chino tradicional

Compatibilidad

VMware Tools 10.1.5 es compatible con versiones admitidas de VMware vSphere ESXi 5.5 y versiones posteriores, VMware Workstation 12.0 y VMware Fusion 8.0. Consulte la Guía de compatibilidad de VMware para obtener más información.

VMware Tools 10.1.5 habilita la compatibilidad con DirectX 10.0 y OpenGL 3.3 en invitados de Windows cuando se utiliza con VMware Workstation 12.0, VMware Fusion 8.0 y versiones de VMware vSphere en las que el dispositivo virtual admita la función requerida. El controlador OpenGL del sistema operativo invitado de VMware para Windows y Linux solo admite el perfil principal OpenGL 3.3. No se admite el perfil de compatibilidad de OpenGL3.3. El controlador del invitado OpenGL solo admite la versión 3.0 para los perfiles de compatibilidad.

La opción del instalador de VMware Tools para sobrescribir los módulos del kernel de Linux que se envían con el sistema operativo está obsoleta. En las futuras versiones de VMware Tools para Linux, la opción para sobrescribir se eliminará del instalador.

Compatibilidad con la personalización del sistema operativo invitado

En la Matriz de compatibilidad con la personalización del sistema operativo invitado se proporciona información sobre los sistemas operativos invitados admitidos para la personalización.

Instalación y actualizaciones para esta versión

VMware Tools se puede descargar en la página de Descarga de productos.

Los paquetes de VMware Tools para distintos sistemas operativos se pueden descargar en la página http://packages.vmware.com/tools/releases/index.html. Para obtener más información sobre cómo instalar OSP, consulte la Guía de instalación de VMware Tools para paquetes específicos de sistemas operativos para las versiones 5.x y 6.x de ESXi.

Los pasos para instalar VMware Tools varían en función de su producto VMware y del sistema operativo invitado que haya instalado. Para obtener información sobre los pasos generales para instalar VMware Tools en la mayoría de productos VMware, consulte las instrucciones de instalación generales de VMware Tools (1014294). Para configurar productLocker de forma que señale a un almacén de datos compartido, consulte el artículo de la base de conocimientos 2004018.

Para obtener instrucciones específicas para instalar, actualizar y configurar VMware Tools, consulte la página Documentación de VMware Tools.

Información de actualización

Compatibilidad de la actualización con futuras versiones de VMware Tools

La actualización es compatible con versiones antiguas de VMware Tools que se envían con ESXi para las que finalizó la compatibilidad con las versiones más recientes de VMware que se envían simultáneamente a la siguiente versión ESXi publicada en el momento en el que finalizó la compatibilidad con otras versiones ESXi.

Compatibilidad para VMware Tools ESXi 5.0 y 5.1

  • Compatibilidad ampliada: está disponible una compatibilidad ampliada para las versiones de VMware Tools que se envían con ESXi 5.0 y 5.1.
  • Actualización: ESXi 5.0 y 5.1 no admiten la actualización de VMware Tools a la versión 10.0.12 para los sistemas operativos invitados heredados. Las máquinas virtuales que ejecutan VMware Tools 10.0.12 son compatibles con ESXi 5.0 y 5.1.

Impacto de la actualización

La compatibilidad con la actualización implica que los usuarios deben seguir un proceso de actualización en dos pasos para obtener versiones posteriores a la versión 10.1.0 de VMware Tools en sistemas operativos invitados que no son heredados.

  1. Actualizar VMware Tools que se envía con ESXi 5.0 o 5.1 a una versión más reciente de la versión 9.4.6 en ESXi 5.5 a VMware Tools 10.1.0 en versiones más recientes de ESXi.
  2. Actualizar VMware Tools a versiones posteriores

Para una actualización sencilla, actualice a la versión de VMware Tools que se incluye en el paquete con la versión compatible de ESXi. 

VMware Tools es compatible con versiones anteriores y posteriores de ESXi. Las versiones más recientes de VMware Tools son compatibles con las versiones de ESXi más antiguas admitidas y viceversa. La actualización de VMware Tools a la versión 10.0.12 es la última actualización compatible para los sistemas operativos invitados heredados en VMware ESXi 5.5, la versión de parche ESXi550-201608001, VMware ESXi 6.0, la versión de parche ESXi600-201608001 y versiones posteriores.

Controladores invitados de Windows instalados por VMware Tools

VMware Tools 10.1.5 admite las siguientes versiones de los controladores en un sistema operativo invitado Windows.

    Controladores de hardware
    Controladores
    Versión
    vmci 9.8.6.0
    vsock 9.8.8.0
    pvscsi 1.3.8.0
    wddm 8.15.1.50
    xpdm 12.1.8.0
    vmxnet3 1.7.3.0 - NDIS 6.0
    vmxnet2 2.2.0.0
    vmmouse 12.5.7.0
    vmusbmouse 12.5.7.0
    vmaudio 5.10.0.3506

    Controladores de software
    Controladores
    Versión
    vmrawdsk.sys 1.1.0.1
    vmmemctl.sys 7.4.1.1
    vmhgfs.sys 11.0.14.2 - Para sistemas operativos Windows Vista y posteriores
    vsepflt.sys 10.1.0.0
    vnetflt.sys 10.1.0.0 - Para firma de código del modo Kernel
    vnetWFP.sys 10.1.0.0

Problemas resueltos

  • Después de actualizar VMware Tools se pierde la configuración de los módulos de autenticación acoplable (PAM) del servicio VMware Tools
    La configuración PAM personalizada de /etv/pam.d/vmtoolsd se pierde tras actualizar VMware Tools, lo que provoca errores de autenticación.

    El problema está resuelto en esta versión.

  • Se produce un error en la instalación y la actualización de VMware Tools en las máquinas virtuales CentOS y Oracle Linux.
    Se produce un error en la instalación y la actualización de VMware Tools en las máquinas virtuales CentOS y Oracle Linux. En los hosts ESXi con una versión anterior a la 6.5 que no admiten la versión 13 del hardware virtual, todas las máquinas virtuales CentOS y Oracle Linux tienen una designación de SO invitado. Para VMware Tools 10.1.0, los invitados CentOS y Oracle Linux están limitados a una compilación que utiliza una versión de glibc anterior a la 2.5.

    Este problema se produce porque linuxPreGlibc25.iso no es parte de la instalación ESXi estándar. Durante el proceso de montaje automático de la ISO de VMware Tools para la instalación, realizado por vCenter Server o vSphere Update Manager, es posible que se produzca un error similar al siguiente:

    Se ha producido un error al acceder al archivo de imagen "/usr/lib/vmware/isoimages/linuxPreGlibc25.iso"

    El problema está resuelto en esta versión.

  • El error de autenticación se notifica como un error desconocido general del sistema.
    Es posible que los intentos de autenticación a través de VGAuth resulten en un error específico de autenticación, como una cuenta o contraseña caducadas. El error específico de autenticación se puede notificar de forma incorrecta como un error desconocido general del sistema, similar al que aparece a continuación:

    Excepción de comunicación: No se ha podido crear un archivo temporal en <DIRECCIÓN_IP>: Error general del sistema: Error desconocido

    El problema está resuelto en esta versión.

  • Se produce un error con un controlador VMXNET3 en las máquinas virtuales Linux con una versión antigua del kernel.
    Las máquinas virtuales RHEL 5 con la versión 2.6.18 del kernel pueden mostrar mensajes de error del kernel cuando está conectado a un grupo de puertos troncal y la VLAN invitada no está configurada en la máquina virtual.

    El problema está resuelto en esta versión.

  • No se puede realizar copias de seguridad de las máquinas virtuales con contenedores Docker activos.
    Al intentar realizar snapshots inactivas, es posible que se produzca un error en los sistemas operativos invitados RHEL 7 que ejecutan contenedores Docker. La versión 1.12.x y posteriores de Docker crean puntos de montaje especiales para los contenedores. Estos puntos de montaje se registran como 'net:[NUMBER]' en lugar de como rutas absolutas de /proc/self/mounts en el sistema.

    Nota: Para consultar el seguimiento del problema realizado por Red Hat, diríjase a Red Hat Bugzilla.

    El problema está resuelto en esta versión.

Problemas conocidos

  • El instalador de VMware Tools genera un error en una máquina virtual FreeBSD 11.0
    En una máquina virtual FreeBSD 11.0, el instalador de VMware Tools muestra un error similar al siguiente:
    'No se pueden iniciar los servicios de VMware Tools'
    El instalador muestra que los servicios de administrador de memoria de invitado y de sistema de archivos de bloqueo no se inician cuando finaliza el proceso de instalación de VMware Tools.

    Solución temporal: Realice los pasos siguientes:

    1. Instale VMware Tools sin la opción -d. 
    2. Responda "No" a la pregunta "¿Desea que este programa invoque al comando por usted ahora?" para invocar /usr/local/bin/vmware-config-tools.pl
    3. Antes de ejecutar VMware Tools por primera vez, debe invocar el siguiente comando para configurarlo:
      "/usr/local/bin/vmware-config-tools.pl"
    4. Ejecute el script de configuración:
      /usr/local/bin/vmware-config-tools.pl --skip-stop-start
    5. Ejecute el comando:
      echo "answer VMMEMCTL_CONFED no" >> /etc/vmware-tools/locations
    6. Inicie VMware Tools.
      /usr/local/etc/rc.d/vmware-tools.sh start

Problemas conocidos de versiones anteriores

Para consultar una lista de problemas conocidos que se aplican de versiones anteriores, haga clic aquí.

  • VMware Tools 10.1.0 no es compatible con VMware Site Recovery Manager 6.1.1 o una versión anterior
    La actualización de VMware Tools a la versión 10.1.0 en una máquina virtual administrada por VMware Site Recovery Manager 6.1.1 o una versión anterior interrumpe los flujos de trabajo de VMware Site Recovery Manager. Las versiones 6.1.2 y 6.5 de VMware Site Recovery Manager son compatibles con VMware Tools 10.1.0.

    Solución temporal: Actualice VMware Site Recovery Manager a la versión 6.1.2 o 6.5 antes de instalar o actualizar VMware Tools a la versión 10.1.0. Si VMware Site Recovery Manager 6.1.1 o una versión anterior administra una máquina virtual, no instale ni actualice VMware Tools a la versión 10.1.0. Este requisito de compatibilidad también se aplica a open-vm-tools 10.1.0, empaquetado por varias ediciones de Linux. Para obtener más información sobre compatibilidad, consulte Matriz de interoperabilidad de productos VMware.
  • Se puede producir un error al intentar instalar VMware Tools en un sistema operativo invitado FreeBSD 6.x o 7.x
    Se puede producir un error al intentar instalar VMware Tools en un sistema operativo invitado FreeBSD 6.x o 7.x similar al siguiente:

    Guest operating system daemon: failed
    Attempting to run vmtoolsd after installation will result in the following error
    "Segmentation fault: 11 (core dumped)"


    Solución temporal: Antes de instalar VMware Tools 10.1.0 en una máquina virtual FreeBSD 6.x o 7.x, realice los siguientes pasos:
    1. Cree el archivo que se indica (si no se ha creado)
       
       /etc/libmap.conf
    2. Agregue lo siguiente al archivo /etc/libmap.conf

       [/usr/local/lib/vmware-tools/]
       libpthread.so.2 libthr.so.2
       libpthread.so libthr.so


    Si VMware Tools 10.1.0 ya está instalado, realice los siguientes pasos:
    1. Actualice el archivo /etc/libmap.conf con lo siguiente

       [/usr/local/lib/vmware-tools/]
       libpthread.so.2 libthr.so.2
       libpthread.so libthr.so
    2. Ejecute /usr/local/bin/vmware-config-tools.pl para completar la configuración

    Nota: Esta solución temporal no se aplica a las máquinas virtuales que ejecutan versiones de FreeBSD posteriores a la 7.x.

  • Se produce un error del marco de agente común en open-vm-tools al compilar en Ubuntu 14.04
    Se produce un error del marco de agente común en open-vm-tools al compilar en Ubuntu 14.04 con una versión de rabbitmq-c inferior a 0.8.0.

    Solución temporal: Actualice rabbitmq-c a la versión 0.8.0 o a una versión posterior para que el marco de agente común sea compatible con TLS1.2.
  • vmusr plug-ins no se carga en Solaris 10 Update 11
    Mientras que VMware Tools 10.1 se ejecuta en sistemas operativos invitados Solaris 10 U11, no se cargan los siguientes complementos de vmusr:
    • libdesktopEvents.so
    • libdndcp.so
    • libresolutionSet.so

    Este problema también aparece con la versión 11.2 de Solaris.

    Solución temporal: Actualizar a Solaris 11.3.
  • Con VMware Tools 10.0.x, los controladores duplicados se pueden cargar en el kernel de Linux
    Este problema se produce cuando los controladores se instalan directamente en /lib/modules/<kernel version>/ . Esto puede derivar a que VMware Tools no detecte correctamente los controladores, lo que causa la instalación de controladores no deseados.
  • Solución temporal: Para solucionar este problema, instale los módulos en el subdirectorio de /lib/modules/<kernel version>/ / antes de instalar o volver a instalar VMware Tools.

    Por ejemplo,
    cd /lib/modules/$(uname -r)/
    mkdir foobar
    mv foo.ko bar.ko foobar/
    depmod -a

     

Contraer lista de problemas conocidos anteriores