Actualizado el: 10 DE DICIEMBRE DE 2020

VMware Tools | 10 de diciembre de 2020 | Compilación 17243207

Compruebe si existen actualizaciones adicionales a las notas de la versión.

Contenido de las Notas de la versión

Estas notas de la versión cubren los temas siguientes:

Novedades

VMware Tools 11.2.1 solo soluciona dos problemas de gráficos de Windows que se mencionan en la sección Problemas resueltos. Los usuarios que no sean de Windows que ya hayan instalado VMware Tools 11.2.0 no necesitan actualizar a la versión 11.2.1. 

Versiones anteriores de VMware Tools

  • Para las versiones anteriores de VMware Tools, consulte la página Documentación de VMware Tools.

Antes de comenzar

  • VMware Tools 11.2.1 admite los siguientes sistemas operativos invitados:
    • windows.iso es compatible con Windows 7 SP1 o Windows Server 2008 R2 SP1 y versiones posteriores. 
      • VMware Tools 11.2.1 depende del paquete redistribuible de Microsoft Visual C++ para Visual Studio 2015, 2017 y 2019, y se proporciona con esta herramienta.
        Al preparar el sistema para la instalación de VMware Tools 11.2.1, asegúrese de que el paquete redistribuible de Microsoft Visual C++ para Visual Studio 2015, 2017 y 2019 está instalado en el sistema como requisito previo. La instalación o actualización de VMware Tools 11.2.1 no es compatible con las versiones de Windows que no cumplen con el requisito previo y los clientes deben seguir utilizando VMware Tools 10.2.x o una versión anterior hasta que se puedan aplicar revisiones o actualizar el sistema operativo Windows para que cumpla con los requisitos previos para VMware Tools 11.2.1. Consulte la actualización de Microsoft KB2977003 para obtener las descargas más recientes de Visual C++ admitidas.
      • Requisitos previos de nivel de sistema operativo de Windows
        • Windows Server 2019
        • Windows Server 2016
        • Windows 10
        • Windows Server 2012 R2 con la actualización KB2919355 de Microsoft
        • Windows 8.1 con la actualización KB2919355 de Microsoft
        • Windows Server 2012 
        • Windows 8
        • Windows Server 2008 R2 Service Pack 1 (SP1) con la actualización KB4474419 de Microsoft.
        • Windows 7 Service Pack 1 (SP1) con la actualización KB4474419 de Microsoft.
    • darwin.iso admite la versión de Mac OS X 10.11 y versiones posteriores.
    • Para obtener detalles sobre linux.iso, consulte las Notas de la versión de VMware Tools 10.3.23.
    • Para obtener detalles sobre solaris.iso, consulte las Notas de la versión de VMware Tools 10.3.10.
  • Las imágenes ISO de VMware Tools se congelan para algunos sistemas operativos invitados de final de vida. Algunas imágenes ISO no se incluyen con ESXi en el VIB tools-light. Para obtener más información, consulte la página Documentación de VMware Tools. Todas las imágenes ISO de VMware Tools se pueden descargar en http://my.vmware.com.
  • VMware Tools for Windows: Los archivos ejecutables (.exe) de los instaladores de 32 bits y 64 bits están disponibles para su descarga. Estos archivos se proporcionan para facilitar el acceso y la instalación de VMware Tools en los sistemas operativos invitados Windows.

Nota importante sobre la actualización a ESXi 6.5 o versiones posteriores

Resolución sobre las incompatibilidades y las directrices generales: Al actualizar los hosts ESXi a ESXi 6.5 o versiones posteriores, y con el uso de versiones anteriores de Horizon View Agent, consulte los artículos de la base de conocimientos:

Internacionalización

VMware Tools 11.2.1 está disponible en los siguientes idiomas:

  • Inglés
  • Francés
  • Alemán
  • Español
  • Italiano
  • Japonés
  • Coreano
  • Chino simplificado
  • Chino tradicional

Aviso de soporte del producto

  • La imagen iso anterior a Windows Vista para VMWare Tools ya no se empaqueta con ESXi. La imagen iso anterior a Windows Vista está disponible para que la descarguen los usuarios que lo requieran. Para obtener información de descarga, consulte la página de Descarga de productos.

Aviso de final de compatibilidad con la función

  • El controlador de aumento se ha eliminado de la versión 11.1.0 de VMware Tools para MacOS.
  • Las herramientas de tar (linux.iso) y los OSP que se proporcionan con la versión 10.3.x de VMware Tools seguirán siendo compatibles. Sin embargo, las versiones posteriores a VMware Tools 10.3.5 solo incluirán correcciones de seguridad y críticas, pero no serán compatibles con las funciones nuevas de estos tipos de VMware Tools (herramientas de tar y OSP). Se recomienda que los clientes utilicen open-vm-tools para aquellos sistemas operativos que son compatibles con open-vm-tools. Para obtener más información sobre los diferentes tipos de VMware Tools, consulte https://blogs.vmware.com/vsphere/2016/02/understanding-the-three-types-of-vm-tools.html

Notas sobre compatibilidad

  • A partir de VMware Tools 10.2.0, ya no se admite la instalación de VMware Tools basada en scripts de Perl para FreeBSD. Los sistemas FreeBSD solo se admitirán mediante los paquetes de open-vm-tools disponibles en los repositorios de paquetes de FreeBSD. Los paquetes de FreeBSD para open-vm-tools 10.1.0 y versiones posteriores están disponibles en los repositorios de paquetes de FreeBSD.

Compatibilidad con la personalización del sistema operativo invitado

En la Matriz de compatibilidad con la personalización del sistema operativo invitado se proporciona información sobre los sistemas operativos invitados admitidos para la personalización.

Matriz de interoperabilidad

La Matriz de interoperabilidad de productos VMware ofrece detalles sobre la compatibilidad de las versiones actuales y anteriores de productos VMware. La matriz de interoperabilidad de productos VMware de VMware Tools 11.2.0 puede aplicarse a VMware Tools 11.2.1.

Instalación y actualizaciones para esta versión

VMware Tools se puede descargar en la página de Descarga de productos.

Los pasos para instalar VMware Tools varían en función de su producto VMware y del sistema operativo invitado que haya instalado. Para obtener información sobre los pasos generales para instalar VMware Tools en la mayoría de los productos VMware, consulte las Instrucciones de instalación generales de VMware Tools (1014294). Para configurar productLocker de forma que señale al almacén de datos compartido, consulte el artículo de la base de conocimientos 2004018.

Para obtener instrucciones específicas para instalar, actualizar y configurar VMware Tools, consulte la página Documentación de VMware Tools.

Controladores invitados de Windows instalados por VMware Tools

VMware Tools 11.2.1 admite las siguientes versiones de los controladores en un sistema operativo invitado Windows.

Controladores VMware Tools 11.2.1
Controladores de hardware
vmci

9.8.16.0

vsock

9.8.17.0

pvscsi

1.3.15.0

wddm

8.17.02.0002

vmxnet3

1.8.16.0

vmxnet2

2.2.0.0

vmmouse

12.5.10.0

vmusbmouse

12.5.10.0

vmaudio

5.10.0.3506

efifw 1.0.0.0
Controladores de software
vmrawdsk.sys

1.1.5.0

vmmemctl.sys

7.5.5.0

vmhgfs.sys

11.0.42.0

vsepflt.sys

11.2.0.0

vnetWFP.sys 

11.2.0.0 

glgxi.sys

2.3.0.0

giappdef

2.3.1.0

DLL de seguridad
vmwsu.dll

2.5.0.0

Problemas resueltos

  • Retraso significativo en el proceso de inicio de las máquinas virtuales de Windows 7 con VMware Tools 11.2.0 instalado.

    Después de encender las máquinas virtuales, se producen aproximadamente 2 minutos de tiempo de pantalla negra antes de que se muestre la ventana de inicio de sesión del usuario. Este problema aparece en las máquinas virtuales de Windows con VMware Tools versión 11.2.0 instalado.

    El problema está resuelto en esta versión.

  • La aplicación "Google Earth" muestra un parpadeo con la API de OpenGL en sistemas operativos Windows 10 invitados.

    Cuando la aplicación "Google Earth" se inicia en una máquina virtual de Windows 10 invitado, se muestra un efecto de parpadeo. La API 3D predeterminada de Google Earth es OpenGL.

    El problema está resuelto en esta versión.

Problemas conocidos

Los problemas conocidos se agrupan del siguiente modo.

Problemas de VMware Tools
  • Después de actualizar VMware Tools a una nueva versión con el parámetro del instalador para eliminar la función NetworkIntrospection, se sigue ejecutando la versión anterior del servicio de controlador vnetflt o vnetWFP.

    Después de la actualización, la función NetworkIntrospection ya no se encuentra en la base de datos MSI de VMware Tools del sistema, pero el servicio de controlador vnetflt o vnetWFP de la función todavía existe.

    Solución temporal:

    Consulte el artículo de la base de conocimientos 78016

    Nota: La actualización futura de VMware Tools de la versión 11.1.0 a una versión más reciente ya no presentará el problema.

  • Se produce un error en la actualización de VMware Tools en Windows 7 SP1 y Windows Server 2008 R2 SP1 sin compatibilidad con la firma de código SHA-2.

    Microsoft ha cambiado la firma de controladores de Windows para usar solo el algoritmo SHA-2, a partir del 3 de diciembre de 2019. Por lo tanto, los sistemas Windows heredados sin compatibilidad con la firma de código SHA-2 fallan durante la verificación de la firma del controlador.

    Solución temporal:

    Consulte el artículo de la base de conocimientos 78708.

  • El controlador de AppDefense glxgi registra un error en el visor de eventos.

    El controlador de AppDefense glxgi registra un error en el visor de eventos, similar al siguiente:

    "The glxgi service failed to start due to the following error: A device attached to the system is not functioning."

    Los eventos se observan cuando se deshabilita la integridad del invitado.

    Solución temporal:

    Estos eventos no afectan al sistema y pueden ignorarse con total seguridad.

  • Es posible que la instalación o actualización de versiones anteriores a VMware Tools 10.3.0 a VMware Tools 11.1.x requiera un cierto tiempo y que sea necesario reiniciar el sistema operativo Windows.

    El proceso de instalación podría aparecer como en curso y mostrar un mensaje similar al siguiente:
    "Preparing 'VMware Tools' for installation..."

    Durante este proceso, es posible que al usuario se le solicite reiniciar el sistema operativo. 

    Para obtener más información, consulte KB 55798.

Problemas de VMware Tools en VMware Workstation o Fusion
  • El montaje de carpetas compartidas no está disponible en máquinas virtuales Linux.

    Si la función Carpetas compartidas está habilitada en una máquina virtual Linux mientras está apagada, el montaje de carpetas compartidas no estará disponible al reiniciar.

    Nota: Este problema afecta a VMware Tools cuando se ejecuta en Workstation y Fusion.

    Solución temporal:

    Si la máquina virtual está encendida, deshabilite y habilite la función Carpetas compartidas desde la interfaz.
    Para resolver el problema permanentemente, edite /etc/fstab y agregue una entrada para montar las carpetas compartidas automáticamente al arrancar.
    Por ejemplo, agregue la línea:
    vmhgfs-fuse   /mnt/hgfs    fuse    defaults,allow_other    0    0

  • La funcionalidad de arrastrar no funciona en Ubuntu.

    La funcionalidad de arrastrar no funciona en la máquina virtual Ubuntu 16.04.4 de 32 bits instalada con la instalación fácil. Además, se observan errores de la funcionalidad de copiar y pegar en el mismo sistema.

    Nota: Este problema afecta a VMware Tools cuando se ejecuta en Workstation y Fusion.

    Solución temporal:

    • Agregue la opción de arranque modprobe.blacklist=vmwgfx del kernel de Linux.
    • Para obtener acceso a unas resoluciones más grandes. elimine la opción svga.guestBackedPrimaryAware = "TRUE" del archivo VMX.
Problema de VMware Tools en VMware Horizon
  • Se produce un error en el controlador WDDM en la instalación de Windows Update cuando Horizon Agent se instala en W8/8.1/WS2008R2.

    Cuando Horizon Agent se instala en W8/8.1/WS2008R2, se produce un error en el controlador WDDM en la instalación de Windows Update.

    El controlador WDDM estará disponible a través del servicio Windows Update cuando se complete el proceso de publicación del controlador.

check-circle-line exclamation-circle-line close-line
Scroll to top icon