Para migrar a Workspace ONE Access Connector 22.05, debe seguir estos requisitos.

  • Necesita uno o varios servidores de Windows para instalar Connector 22.05. Los servicios de sincronización de directorios, autenticación de usuario, autenticación Kerberos y aplicaciones virtuales se pueden instalar juntos en un servidor o por separado en servidores diferentes. Para obtener más información sobre los requisitos, consulte Instalar VMware Workspace ONE Access Connector 22.05.

    Puede instalar Connector 22.05 en un servidor nuevo o en el servidor de Connector 19.03.xheredado. Sin embargo, si la autenticación Kerberos está configurada en el conector heredado, debe instalar el servicio de autenticación Kerberos 22.05 en un servidor independiente. No instale el nuevo servicio de autenticación Kerberos en el servidor de Connector 19.03.x. Workspace ONE Access no admite varias instancias de Kerberos en el mismo servidor.

    Si tiene pensado instalar Connector 22.05 en un nuevo servidor Windows, consulte Requisitos del sistema de Workspace ONE Access Connector 22.05 en Instalar VMware Workspace ONE Access Connector 22.05. Si tiene pensado instalar Connector 22.05 en el servidor de Connector 19.03.x, consulte Migrar a la versión más reciente de Connector en un servidor Windows que ejecute Workspace ONE Access 19.03.x .

  • Si la instalación existente incluye aplicaciones virtuales de Citrix, cuando instale el servicio de aplicaciones virtuales, asegúrese de seguir los requisitos y los requisitos previos para la integración de Citrix descritos en la guía Instalar VMware Workspace ONE Access Connector 22.05. Estos incluyen:
    • El servidor del conector debe estar unido al dominio del directorio.
    • Debe especificar una cuenta de usuario de dominio para ejecutar el servicio de aplicaciones virtuales. El usuario de dominio también debe ser un administrador de solo lectura del servidor de Citrix que pueda cargar Citrix PSSnapin.
    • Debe instalar Citrix Studio en el servidor de Connector. Citrix Studio incluye Citrix PowerShell SDK, que es necesario para la integración entre Citrix y Workspace ONE Access. La versión de Citrix Studio debe ser compatible con la versión de implementación de Citrix.
  • Para las colecciones de aplicaciones virtuales de Horizon y Horizon Cloud, asegúrese de que las instancias de Horizon Connection Server tengan certificados válidos firmados por una entidad de certificación (CA) de confianza. Si las instancias de Horizon Connection Server tienen certificados autofirmados, debe cargar la cadena de certificados en las instancias de Workspace ONE Access Connector en las que está instalado el servicio de aplicaciones virtuales para establecer confianza entre las instancias de Connector y las de Horizon Connection Server. Este es un nuevo requisito a partir de Workspace ONE Access Connector 21.08. Los certificados se cargan mediante el instalador del conector. Para obtener más información, consulte Instalar VMware Workspace ONE Access Connector 22.05. Asegúrese de reiniciar los servicios de Connector después de cargar los certificados.
  • Durante el proceso de migración, alternará el uso de los conectores anteriores y los nuevos conectores para probar la migración. Los servidores de conectores heredados 19.03.x deben estar en ejecución durante el proceso de migración. No desinstale instancias de Connector 19.03.x hasta que se complete la migración.
  • Todas las instancias de Connector existentes en el arrendatario deben ser de la versión 19.03.x. Si tiene instancias más antiguas, primero actualícelas a la versión 19.03.x.
  • Durante la migración, debe migrar todos los directorios y colecciones de aplicaciones virtuales compatibles del arrendatario a Connector 22.05. No puede elegir migrar un subconjunto de los directorios o aplicaciones virtuales, ni migrar solo los directorios o las aplicaciones virtuales.
  • Si va a instalar el servicio de autenticación de usuario, asegúrese de que todos los conectores en los que esté instalado el servicio de autenticación de usuario sean de la versión 22.05. Workspace ONE Access no admite la combinación de versiones 22.05, 21.08.x y 20.x del servicio de autenticación de usuario.
  • Después de la migración, solo se pueden utilizar los nuevos Connector 22.05. No puede tener una combinación de versiones más antiguas de Connector 19.03.x y Connector 22.05 en su entorno.
  • Workspace ONE Access Connector 22.05 admite los siguientes tipos de proxies:
    • Proxies HTTP sin autenticar
    • Proxies no autenticados HTTPS (SSL)
    • Proxies HTTPS autenticados (SSL)

Migrar a la versión más reciente de Connector en un servidor Windows que ejecuta Workspace ONE Access Connector 19.03.x

Cuando no puede adquirir un nuevo servidor Windows para migrar a Workspace ONE Access Connector 22.05, puede instalar Connector 22.05 en un servidor Windows que ejecute Workspace ONE Access Connector 19.03.x. A continuación, puede migrar la instancia de Connector heredada.

Precaución: Si la autenticación Kerberos está configurada en el conector heredado, debe instalar el nuevo servicio de autenticación Kerberos 22.05 en un servidor Windows independiente. No instale el servicio de autenticación Kerberos en el servidor de Connector 19.03. x. Workspace ONE Access no admite varias instancias de Kerberos en el mismo servidor.

Si utiliza un servidor Windows existente que tenga instalado Connector 19.03.x, asegúrese de seguir estas directrices:

  • Antes de instalar Connector 22.05, debe aumentar la CPU y la memoria en el servidor. Se ejecutarán dos versiones de Connector hasta que se complete la migración.

    Debe aumentar la CPU y la memoria para satisfacer las necesidades de Connector 19.03.x y 22.05. Consulte las directrices de dimensionamiento de la versión 22.05 en Instalar VMware Workspace ONE Access Connector 22.05.

  • IMPORTANTE: Tome una instantánea de la máquina antes de ejecutar el instalador de Connector 22.05. Al instalar Connector 22.05, al final del proceso de instalación, es posible que se le solicite reiniciar el host de Connector. No reinicie el host. Si lo hace, se producirá un error en el proceso de migración y la versión de Connector 19.03.x quedará inutilizable. Es fundamental que no reinicie la máquina hasta que se complete todo el proceso de migración. Cuando la migración se completa correctamente, puede reiniciar la máquina de forma segura.
  • No detenga ni desinstale Connector 19.03.x hasta que se complete todo el proceso de migración.

Una vez finalizada la migración, puede detener la instancia de Connector 19.03.x y desinstalarla.