Puede actualizar VMware Tools manualmente o configurar las máquinas virtuales para que busquen e instalen versiones más recientes de VMware Tools.

El sistema operativo invitado comprueba la versión de VMware Tools cuando enciende una máquina virtual. La barra de estado de su máquina virtual mostrará un mensaje cuando haya una nueva versión disponible.

En las máquinas virtuales Windows, puede configurar VMware Tools para que le avise cuando haya una actualización disponible. Si la opción de notificación está activada, el icono de VMware Tools de la barra de tareas de Windows incluirá un icono de alerta amarillo cuando esté disponible una actualización de VMware Tools.

Para instalar una actualización de VMware Tools, puede utilizar el mismo procedimiento que usó para instalar VMware Tools la primera vez. La actualización de VMware Tools significa que se instala una nueva versión.

En los sistemas operativos invitados Windows y Linux, puede configurar la máquina virtual para que VMware Tools se actualice automáticamente. Aunque se realiza una verificación de la versión al encender la máquina virtual, en los sistemas operativos invitados Windows, la actualización automática se realiza cuando enciende o reinicia la máquina virtual. La barra de estado muestra el mensaje Instalando VMware Tools... cuando se está realizando una actualización.

Importante:

Tras actualizar VMware Tools en los sistemas operativos invitados Linux, hay disponibles nuevos módulos de red. Sin embargo, estos no se utilizan hasta que reinicia el sistema operativo invitado o detiene la conexión de red, descarga y vuelve a cargar los módulos del kernel de red de VMware, y reinicia la conexión de red. Esto significa que aunque VMware esté configurado para actualizarse automáticamente, deberá reiniciar o volver a cargar los módulos de red para que las nuevas funciones estén disponibles.

Esta estrategia evita las interrupciones en la red y le permite instalar VMware Tools mediante SSH.

Al actualizar VMware Tools en sistemas operativos invitados Windows, se instalan automáticamente controladores gráficos WDDM. Estos controladores permiten establecer el modo de suspensión en la configuración de encendido del SO invitado para ajustar las opciones de este modo. Por ejemplo, puede utilizar la opción del modo de suspensión Cambiar la frecuencia con la que el equipo entra en estado de suspensión para establecer que el SO invitado entre en modo de suspensión automáticamente después de un cierto tiempo o para evitar que cambie a este modo tras estar inactivo durante un tiempo.

Para las máquinas virtuales de vSphere, puede utilizar uno de los siguientes procesos para actualizar varias máquinas virtuales al mismo tiempo.

  • Inicie sesión en vCenter Server, seleccione un host o clúster y, en la pestaña Máquinas virtuales, especifique las máquinas virtuales en las cuales se realizará la actualización de VMware Tools.

  • Utilice el Administrador de actualizaciones para realizar una actualización organizada de máquinas virtuales a nivel de carpeta o de centro de datos.

Algunas funciones de una versión específica de un producto de VMware pueden depender de la instalación de la versión de VMware Tools incluida en ese lanzamiento o de la actualización a la misma. Actualizar a la última versión de VMware Tools no es siempre necesario. Las versiones más nuevas de VMware Tools son compatibles con varias versiones de host. Para evitar actualizaciones innecesarias, determine si las funciones y características añadidas son necesarias para su entorno.

Tabla 1. Opciones de compatibilidad de máquinas virtuales

Compatibilidad

Descripción

ESXi 6.0 y versiones posteriores

Esta máquina virtual (hardware versión 11) es compatible con ESXi 6.0 y versiones posteriores.

ESXi 5.5 y versiones posteriores

Esta máquina virtual (hardware versión 10) es compatible con ESXi 5.5 y versiones posteriores.

ESXi 5.1 y versiones posteriores

Esta máquina virtual (hardware versión 9) es compatible con ESXi 5.1 y versiones posteriores.

ESXi 5.0 y versiones posteriores

Esta máquina virtual (hardware versión 8) es compatible con ESXi 5.0 y 5.1.

ESX/ESXi 4.x y versiones posteriores

Esta máquina virtual (hardware versión 7) es compatible con ESX/ ESXi 4.x, ESXi 5.0 y ESXi 5.1.

ESX/ESXi 3.5.x y versiones posteriores

Esta máquina virtual (versión de hardware 4) es compatible con ESX/ESX 3.5. ESX/ESX 4.x y ESXi 5.1, así como con VMware Server 1.0 y versiones posteriores. No puede crear una máquina virtual con compatibilidad ESX/ESXi 3.5 en ESXi 5.0.

Para obtener más información, consulte la documentación del producto de VMware específico.