Un host puede tener paquetes de instalación (VIB) personalizados de vSphere instalados (por ejemplo, para agentes de administración o controladores de otros fabricantes). Cuando se actualiza un host ESXi 5.x a ESXi 6.0, se migran todos los VIB personalizados compatibles, independientemente de si los VIB se incluyen en el archivo ISO del instalador.

Si el host o la imagen ISO del instalador contienen un VIB que genera un conflicto e impide la actualización, un mensaje de error identifica el VIB que generó el conflicto. Para actualizar el host, realice una de estas acciones:

  • Quite el VIB que generó el conflicto del host y vuelva a intentar ejecutar la actualización. Si usa vSphere Update Manager, seleccione la opción para quitar los módulos de software de otros fabricantes durante el proceso de corrección. Para obtener más información, consulte la documentación sobre Instalación y administración de VMware vSphere Update Manager. También puede quitar el VIB que generó el conflicto desde el host mediante los comandos esxcli. Para obtener más información, consulte Quitar VIB de un host.

  • Use vSphere ESXi Image Builder CLI para crear una imagen ISO personalizada de instalador que solucione el conflicto. Para obtener más información sobre la instalación y el uso de vSphere ESXi Image Builder CLI, consulte la documentación de Instalación y configuración de vSphere.