Se produce un error en la instalación de vCenter Server con una base de datos de Microsoft SQL cuando la base de datos está configurada en modo de compatibilidad con una versión no compatible.

Aparece el siguiente mensaje de error: El usuario de base de datos ingresado no tiene los permisos necesarios para instalar y configurar vCenter Server con la base de datos seleccionada. Corrija los siguientes errores: %s

La versión de la base de datos debe ser compatible para vCenter Server. En el caso de SQL, aunque la base de datos sea de una versión compatible, si se configura para que se ejecute en modo de compatibilidad con una versión no compatible, se produce este error. Por ejemplo, si SQL 2008 está configurada para que ejecute el modo de compatibilidad de SQL 2000, se presenta este error.

Procedimiento

Asegúrese de que la base de datos de vCenter Server sea de una versión compatible y no esté configurada en el modo de compatibilidad con una versión no compatible. Consulte las matrices de interoperabilidad de productos VMware en http://partnerweb.vmware.com/comp_guide2/sim/interop_matrix.php?.