Cuando se intenta desmontar o eliminar un almacén de datos, se produce un error en la operación.

Problema

Se produce un error en la operación para desmontar o eliminar un almacén de datos si el almacén de datos tiene archivos abiertos. Para estas operaciones de usuarios, el agente de vSphere HA cierra todos los archivos que tiene abiertos, por ejemplo archivos de latido. Si vCenter Server no puede acceder al agente o el agente no puede purgar E/S pendientes para cerrar los archivos, se acciona el error El agente de HA en el host '{hostName}' presentó error al poner en modo inactivo la actividad del archivo en el almacén de datos {dsName}.

Causa

Si el almacén de datos que se va a desmontar o eliminar se utiliza para verificación de latidos, vCenter Server lo excluye de la verificación de latidos y selecciona uno nuevo. Sin embargo, el agente no recibe los almacenes de datos con latido actualizado si no se puede acceder a él, es decir, si el host está aislado o en una partición de red. En dichos casos, los archivos de latido no se cierran y se produce un error de operación de usuario. La operación también puede presentar error si no se puede acceder al almacén de datos debido a errores de almacenamiento, como caída de todas las rutas de acceso.

Nota: Cuando elimina un almacén de datos de VMFS, este almacén se quita de todos los hosts en el inventario. Por lo tanto, si hay hosts en un clúster de vSphere HA a los que no se puede acceder o que no tienen acceso al almacén de datos, hay error en la operación.

Solución

Asegúrese de que el almacén de datos esté accesible y que se pueda acceder a los hosts afectados.