El script de comprobación previa a la instalación y actualización realiza pruebas para identificar los problemas del equipo host que pueden ocasionar que la migración, actualización o instalación sean incorrectas.

En el caso de instalaciones, actualizaciones y migraciones interactivas, los errores o las advertencias se muestran en el panel final del instalador, donde se le pide que confirme o cancele la instalación o actualización. En el caso de instalaciones, actualizaciones o migraciones por script, los errores o las advertencias se escriben en el archivo de registro de instalación.

vSphere Update Manager proporciona mensajes personalizados para estos errores o estas advertencias. Para ver los errores y las advertencias originales devueltos por el script de comprobación previa durante un análisis de actualización de host de Update Manager, revise el archivo de registro vmware-vum-server-log4cpp.log de Update Manager.

Tabla 1. Códigos de error y advertencia devueltos por el script de comprobación previa a la instalación y actualización

Error o advertencia

Descripción

64BIT_LONGMODESTATUS

El procesador de host debe ser de 64 bits.

COS_NETWORKING

Advertencia. Se encontró una dirección IPv4 en una NIC virtual de consola de servicio habilitada que no tiene una dirección correspondiente en la misma subred del vmkernel. Aparece una advertencia aparte para cada uno de los casos.

CPU_CORES

El host debe tener al menos dos núcleos.

DISTRIBUTED_VIRTUAL_SWITCH

Si no se encuentra el software Cisco Virtual Ethernet Module (VEM) en el host, la prueba se asegura de que la actualización contenga también el software VEM. Además, la prueba determina si la actualización admite la misma versión de Cisco Virtual Supervisor Module (VSM) que la que hay en el host. Si falta el software o no es compatible con otra versión de VSM, la prueba devuelve una advertencia. El resultado indica qué versión del software VEM se esperaba detectar en el archivo ISO de actualización y qué versiones se encontraron, si es que había alguna. Puede utilizar ESXi Image Builder CLI para crear un archivo ISO de instalación personalizado que incluya la versión adecuada del software VEM.

HARDWARE_VIRTUALIZATION

Advertencia. Si el procesador del host no tiene virtualización de hardware o si esta no está activada en el BIOS del host, el rendimiento del host se resiente. Habilite la virtualización de hardware en las opciones de arranque del equipo host. Consulte la documentación del proveedor de hardware.

MD5_ROOT_PASSWORD

Esta prueba se asegura de que la contraseña raíz esté codificada en formato MD5. Si una contraseña no está codificada en formato MD5, posiblemente solo se consideren ocho caracteres. En este caso, los caracteres que aparecen después de los ocho primeros ya no se autentican después de la actualización, lo cual puede ocasionar un problema de seguridad. Para encontrar una solución alternativa a este problema, consulte el artículo de la base de conocimientos de VMware 1024500.

MEMORY_SIZE

El host requiere la cantidad de memoria especificada para la actualización.

PACKAGE_COMPLIANCE

Solo vSphere Update Manager. Esta prueba compara el software existente en el host con el software que contiene el archivo ISO de actualización para determinar si el host se actualizó correctamente. Si falta algún paquete o alguno tiene una versión más antigua que el paquete del archivo ISO de actualización, la prueba devuelve un error e indica qué software se encontró en el host y qué software había en el archivo ISO de actualización.

PARTITION_LAYOUT

Puede actualizar o migrar software solo si se actualiza una partición de VMFS del disco como máximo. Además, la partición de VMFS debe comenzar después del sector 1843200.

POWERPATH

Esta prueba busca instalaciones de software EMC PowerPath, que consta de un módulo CIM y uno de kernel. Si se detecta alguno de estos componentes en el host, la prueba se asegura de que en la actualización existan también los componentes coincidentes, como CIM, vmkernel y module. Si no se encuentran, la prueba devuelve una advertencia que indica qué componentes de PowerPath se esperaba encontrar en el archivo ISO de actualización y cuáles se detectaron, si es que había alguno.

PRECHECK_INITIALIZE

Esta prueba se asegura de que el script de comprobación previa pueda ejecutarse.

SANE_ESX_CONF

El archivo /etc/vmware/esx.conf debe estar presente en el host.

SPACE_AVAIL_ISO

Solo vSphere Update Manager. El disco host debe tener espacio libre suficiente para almacenar el contenido del CD o DVD del instalador.

SPACE_AVAIL_CONFIG

Solo vSphere Update Manager. El disco host debe tener espacio libre suficiente para almacenar la configuración heredada entre un reinicio y otro.

SUPPORTED_ESX_VERSION

Solo se puede actualizar o migrar a hosts ESXi 6.5 desde las versiones ESXi 5.5 o 6.0.

TBOOT_REQUIRED

Este mensaje se aplica solo a las actualizaciones de vSphere Update Manager. La actualización genera este error cuando el sistema host se ejecuta en el modo de arranque de confianza (tboot), pero el archivo ISO de actualización de ESXi no contiene ningún VIB de tboot. Esta prueba evita las actualizaciones que pueden disminuir la seguridad del host.

UNSUPPORTED_DEVICES

Advertencia. Esta prueba busca dispositivos no compatibles. Algunos dispositivos PCI no son compatibles con ESXi 6.5.

UPDATE_PENDING

Esta prueba busca en el host instalaciones por VIB que requieran un reinicio. La prueba es incorrecta si hay uno o más de estos VIB instalados, pero el host aún no se reinició. En estas condiciones, el script de comprobación previa no puede determinar con confianza qué paquetes están actualmente instalados en el host. Por ello, es posible que no sea prudente basarse en el resto de las pruebas de comprobación previa para saber si una actualización es segura o no.

Si encuentra este error, reinicie el host y vuelva a intentar actualizar.