Al crear o actualizar una máquina virtual existente, se usa la funcionalidad de compatibilidad de máquinas virtuales para seleccionar las versiones de host ESXi en las que puede ejecutarse la máquina virtual.

La configuración de compatibilidad determina el hardware virtual disponible para la máquina virtual, que corresponde al hardware físico disponible en el host. El hardware virtual incluye BIOS y EFI, las ranuras de PCI virtuales disponibles, la cantidad máxima de CPU, la configuración máxima de memoria y otras características. Por lo general, las nuevas funcionalidades de hardware virtual se lanzan una vez al año mediante versiones con actualizaciones menores o importantes de vSphere.

Cada nivel de compatibilidad de máquinas virtuales admite, al menos, cinco versiones con actualizaciones menores o importantes de vSphere. Por ejemplo, una máquina virtual compatible con ESXi 3.5 y posterior puede ejecutarse en ESXi 3.5, ESXi 4.0, ESXi 4.1, ESXi 5.0, ESXi 5.1, ESXi 5.5, ESXi 6.0 y ESXi 6.5.

Tabla 1. Opciones de compatibilidad de máquinas virtuales

Compatibilidad

Descripción

ESXi 6.5 y versiones posteriores

Esta máquina virtual (versión de hardware 13) es compatible con ESXi 6.5.

ESXi 6.0 y posterior

Esta máquina virtual (versión de hardware 11) es compatible con ESXi 6.0 y ESXi 6.5.

ESXi 5.5 y posterior

Esta máquina virtual (versión de hardware 10) es compatible con ESXi 5.5, ESXi 6.0 y ESXi 6.5.

ESXi 5,1 y posterior

Esta máquina virtual (versión de hardware 9) es compatible con ESXi 5.1, ESXi 5.5, ESXi 6.0 y ESXi 6.5.

ESXi 5.0 y posterior

Esta máquina virtual (versión de hardware 8) es compatible con ESXi 5.0, ESXi 5.1, ESXi 5.5, ESXi 6.0 y ESXi 6.5.

ESX/ESXi 4.0 y posterior

Esta máquina virtual (versión de hardware 7) es compatible con ESX/ESXi 4.0, ESX/ESXi 4.1, ESXi 5.0, ESXi 5.1, ESXi 5.5, ESXi 6.0 y ESXi 6.5.

ESX/ESXi 3.5 y posterior

Esta máquina virtual (versión de hardware 4) es compatible con ESX/ESXi 3.5, ESX/ESXi 4.0, ESX/ESXi 4.1, ESXi 5.1, ESXi 5.5, ESXi 6.0 y ESXi 6.5. También es compatible con VMware Server 1.0 y versiones posteriores. ESXi 5.0 no admite la creación de máquinas virtuales compatibles con ESX/ESXi 3.5 y posterior, pero es posible ejecutar esas máquinas virtuales si se crearon en un host con compatibilidad diferente.

ESX Server 2.x y posterior

Esta máquina virtual (versión de hardware 3) es compatible con ESX Server 2.x, ESX/ESXi 3.5, ESX/ESXi 4.x y ESXi 5.0. No se permite crear, editar, encender, clonar ni migrar máquinas virtuales compatibles con ESX Server 2.x. Solo es posible registrarlas o actualizarlas.

La configuración de compatibilidad que aparece en el menú desplegable Compatible con es la configuración predeterminada para la máquina virtual que está creando. Los factores siguientes determinan la compatibilidad predeterminada de las máquinas virtuales:

  • La versión de host ESXi en la que se creó la máquina virtual.

  • El objeto de inventario en el que se estableció la compatibilidad de máquina virtual predeterminada, incluidos hosts, clústeres o centros de datos.

Puede aceptar la opción de compatibilidad predeterminada o seleccionar otra opción. No siempre es necesario seleccionar la versión de host más reciente de ESXi. Se puede obtener mayor flexibilidad si se selecciona una versión anterior, y esta acción puede resultar útil en las situaciones siguientes:

  • Para estandarizar las pruebas y la implementación en el entorno virtual.

  • Si no se dispone de las funcionalidades de la versión de host más reciente.

  • Para mantener la compatibilidad con hosts anteriores.

Al crear una máquina virtual, tenga en cuenta el entorno en el que se ejecutará la máquina virtual y evalúe los beneficios de las diferentes estrategias de compatibilidad. Evalúe sus opciones para estos escenarios, que demuestran la flexibilidad que aporta cada selección de compatibilidad de máquinas virtuales.

Objetos en el entorno

Compatibilidad

Resultados

Clúster con hosts ESXi 5.5, ESXi 6.0 y ESXi 6.5

ESXi 5.5 y posterior

Mantiene la capacidad que permite que la máquina virtual se ejecute en otros hosts del clúster, por ejemplo, ESXi 5.5.

Es posible que no tenga acceso a las características de hardware virtual más recientes.

Clúster con hosts ESXi 5.5, ESXi 6.0 y ESXi 6.5

ESXi 6.0 y posterior

Proporciona acceso a características de hardware virtual que no están disponibles con ESXi 5.5.

  • No es posible migrar esta máquina virtual a un host ESXi 5.5.

  • Esta máquina virtual no cuenta con todas las funcionalidades que están disponibles para las máquinas virtuales que se ejecutan en ESXi 6.5. Por ejemplo, no es posible configurar una máquina virtual para usar 256 CPU virtuales.

Clúster con hosts ESXi 5.5, ESXi 6.0 y ESXi 6.5

ESXi 6.5 y versiones posteriores

Proporciona acceso a las características más recientes de hardware virtual, pero no puede ejecutarse en ESXi 5.5 ni ESXi 6.0.

Para obtener información sobre la administración de la compatibilidad de máquinas virtuales, consulte la documentación de Administrar máquinas virtuales de vSphere.