Al desmontar un almacén de datos en VMware Host Client, el almacén de datos permanece intacto, pero ya no se puede ver en el inventario del host que administra. El almacén de datos sigue apareciendo en los demás hosts en los que permanece montado.

No realice ninguna operación de configuración que pueda provocar operaciones de E/S en el almacén de datos mientras el desmontaje está en curso.

Requisitos previos

Nota: Asegúrese de que los latidos de vSphere HA no usen el almacén de datos. Los latidos de vSphere HA no le impiden desmontar el almacén de datos. Sin embargo, si el almacén de datos se utiliza para los latidos, desmontarlo puede provocar que el host genere errores y reinicie todas las máquinas virtuales activas.
Antes de desmontar un almacén de datos, asegúrese de que se cumplan los siguientes requisitos previos:
  • Ninguna máquina virtual debe residir en el almacén de datos.
  • Storage DRS no administra el almacén de datos.
  • Storage I/O Control debe estar desactivado para este almacén de datos.

Procedimiento

  1. Haga clic en Almacenamiento en el inventario de VMware Host Client y, a continuación, haga clic en Almacenes de datos.
  2. Haga clic con el botón derecho en el almacén de datos para desmontarlo de la lista y, a continuación, haga clic en Desmontar.
  3. Confirme que desea desmontar el almacén de datos.

Errores en el desmontaje o la eliminación de un almacén de datos

Cuando se intenta desmontar o eliminar un almacén de datos, se produce un error en la operación.

Problema

Se produce un error en la operación para desmontar o eliminar un almacén de datos si el almacén de datos tiene archivos abiertos. Para estas operaciones de usuarios, el agente de vSphere HA cierra todos los archivos que tiene abiertos, por ejemplo archivos de latido. Si vCenter Server no puede acceder al agente o el agente no puede purgar E/S pendientes para cerrar los archivos, se acciona el error El agente de HA en el host '{hostName}' presentó error al poner en modo inactivo la actividad del archivo en el almacén de datos {dsName}.

Causa

Si el almacén de datos que se va a desmontar o eliminar se utiliza para verificación de latidos, vCenter Server lo excluye de la verificación de latidos y selecciona uno nuevo. Sin embargo, el agente no recibe los almacenes de datos con latido actualizado si no se puede acceder a él, es decir, si el host está aislado o en una partición de red. En dichos casos, los archivos de latido no se cierran y se produce un error de operación de usuario. La operación también puede presentar error si no se puede acceder al almacén de datos debido a errores de almacenamiento, como caída de todas las rutas de acceso.

Nota: Cuando elimina un almacén de datos de VMFS, este almacén se quita de todos los hosts en el inventario. Por lo tanto, si hay hosts en un clúster de vSphere HA a los que no se puede acceder o que no tienen acceso al almacén de datos, hay error en la operación.

Solución

Asegúrese de que el almacén de datos esté accesible y que se pueda acceder a los hosts afectados.