En determinadas circunstancias, es posible que deba volver a registrar la instancia de OIDC de vCenter Server en NSX Manager (por ejemplo, cuando el FQDN o el PNID de vCenter Server cambian).
Procedimiento
No se puede cambiar la contraseña de NSX Appliance
Es posible que no pueda cambiar la contraseña de NSX Appliance para los usuarios root
, admin
o audit
.
Problema
Puede que se produzcan errores en los intentos de cambiar la contraseña de NSX Appliance para los usuarios root
, admin
o audit
en vSphere Client.
Causa
Durante la instalación de NSX Manager, el procedimiento solo acepta una contraseña para las tres funciones. Se podría producir un error al intentar cambiar esta contraseña más tarde.
Solución
- ♦ Utilice las API de NSX para cambiar las contraseñas.
Para obtener más información, consulte https://kb.vmware.com/s/article/70691 y la Guía de administración de NSX.
Solucionar problemas de flujos de trabajo con errores e instancias de NSX Edge inestables
Si se produce un error en los flujos de trabajo o las instancias de NSX Edge son inestables, puede realizar los pasos de solución de problemas.
Problema
Al cambiar la configuración del grupode puertos distribuidos en vSphere Client, se pueden producir errores en los flujos de trabajo y las instancias de NSX Edge pueden volverse inestables.
Causa
Por diseño, no se permite la eliminación ni la modificación de los grupos de puertos distribuidos para la superposición y el vínculo superior que se crearon durante la fase de configuración del clúster de NSX Edge de los ajustes del clúster.
Solución
Si necesita cambiar la configuración de la VLAN o del grupo de direcciones IP de las instancias de NSX Edge, primero debe eliminar los elementos de NSX y la configuración de vSphere IaaS control plane del clúster.
Para obtener información sobre cómo eliminar elementos de NSX, consulte la Guía de instalación de NSX.
Recopilar paquetes de soporte para la solución de problemas de NSX
Puede recopilar paquetes de soporte en los nodos de clúster y tejido registrados para solucionar problemas y descargar los paquetes en su máquina o cargarlos en un servidor de archivos.
Si decide descargar los paquetes en su máquina, obtendrá un solo archivo de almacenamiento compuesto por un archivo de manifiesto y paquetes de soporte para cada nodo. Si elige cargar los paquetes en un servidor de archivos, el archivo de manifiesto y los paquetes individuales se cargan en el servidor de archivos por separado
Procedimiento
Recopilar archivos de registro para NSX
Puede recopilar los registros que se encuentran en los componentes de vSphere IaaS control plane y NSX para detectar errores y solucionarlos. Los archivos de registro pueden solicitarse a través del soporte de VMware.
Procedimiento
- Inicie sesión en vCenter Server mediante vSphere Client.
- Recopile los siguientes archivos de registro.
Archivo de registro Descripción /var/log/vmware/wcp/wcpsvc.log Contiene información relacionada con la habilitación de vSphere IaaS control plane. /var/log/vmware/wcp/nsxd.log Contiene información relacionada con la configuración de los componentes de NSX. - Inicie sesión en NSX Manager.
- Recopile el archivo /var/log/proton/nsxapi.log para obtener información sobre el error que NSX Manager devuelve cuando se produce un error en una operación de vSphere IaaS control plane específica.
Reiniciar el servicio WCP si la dirección IP, la huella digital o el certificado de administración de NSX cambian
Si la dirección IP, la huella digital o el certificado de administración de NSX cambian después de instalar vSphere IaaS control plane, debe reiniciar el servicio WCP
.
Reiniciar el servicio vSphere IaaS control plane si el certificado de NSX cambia
Actualmente, según los requisitos de vSphere IaaS control plane, si la huella digital o el certificado de NSX o la dirección IP de NSX cambian, es necesario reiniciar el servicio WCP
para que se implemente el cambio. Si se realiza el cambio sin reiniciar el servicio, se produce un error en la comunicación entre vSphere IaaS control plane y NSX, y se pueden presentar ciertos síntomas, como que NCP ingrese en la etapa CrashLoopBackoff o que los recursos del Supervisor no se puedan implementar.
WCP
, utilice
vmon-cli
.
- Ejecute SSH en vCenter Server e inicie sesión como usuario raíz.
- Ejecute el comando
shell
. - Ejecute el comando
vmon-cli -h
para ver las opciones y la sintaxis de uso. - Ejecute el comando
vmon-cli -l
para ver el proceso dewcp
.Verá el servicio
wcp
en la parte inferior de la lista. - Ejecute el comando
vmon-cli --restart wcp
para reiniciar el serviciowcp
.Verá el mensaje
Completed Restart service request
. - Ejecute el comando
vmon-cli -s wcp
y compruebe que se haya iniciado el serviciowcp
.Por ejemplo:root@localhost [ ~ ]# vmon-cli -s wcp Name: wcp Starttype: AUTOMATIC RunState: STARTED RunAsUser: root CurrentRunStateDuration(ms): 22158 HealthState: HEALTHY FailStop: N/A MainProcessId: 34372