No puede agregar la cuenta de AWS que desea seguir y analizar mediante vRealize Business for Cloud.

Problema

En la pestaña Administración, cuando intenta agregar una cuenta de AWS, aparece un error de recopilación de datos de AWS en el estado del sistema. Revise el archivo itfm-server.log para obtener más detalles sobre el error.

Causa

El problema podría ocurrir debido a una de las siguientes razones.
  • Al agregar una cuenta, las cuentas de pago no se marcan como primarias.
  • El archivo CSV de AWS es demasiado grande y supera el espacio de almacenamiento disponible en el dispositivo virtual vRealize Business for Cloud.
  • No habilitó el informe de facturación detallado para las cuentas de pago.
  • El identificador de la cuenta contiene caracteres o alfabetos especiales, o su longitud es mayor que 12 caracteres.
  • El informe de facturación no está disponible en el contenedor S3.
  • No tiene permisos para agregar la cuenta.

Solución

  • Para solucionar este problema, realice el paso que corresponda de las siguientes soluciones.
    • Al agregar una cuenta, compruebe que la cuenta de pago esté marcada como primaria.
    • Habilite la opción de facturación detallada para las cuentas de pago.
    • Compruebe que el identificador de cuenta no contenga caracteres especiales.
    • Asegúrese de que al menos un informe de facturación presente en el contenedor S3 siga esta convención de nomenclatura: 123456789012-aws-billing-detailed-line-items-with-resources-and-tags-yyyy-mm.csv.zip; donde 123456789012 es el identificador de cuenta, yyyy es el año y mm es el mes.
    • Para una cuenta de pago, asegúrese de que el usuario de AWS tenga los permisos necesarios, como s3:Get*, s3:List* y ec2:Describe*.

      Para una cuenta que no sea de pago, compruebe que el usuario de AWS tenga el permiso ec2:Describe*.