El estado de cálculo de costes podría indicar un error.

Problema

Tras un error de cálculo de costes, cuando consulte el archivo itfm-server.log, es posible que se muestre el mensaje de error No se pudo consultar FactsRepo con la consulta: recuperar 'storageGB' antes de [time,time].

Causa

Este problema se produce cuando se obtiene el estado de cálculo de costes desde el servicio de inventario FactsRepo mientras el servicio está ocupado.

Solución

  1. Inicie sesión en la máquina virtual de vRealize Business for Cloud.
  2. Ejecute el comando /usr/ITFM-Cloud/va-tools/bin/configclient.py GET -k query.source.batching.

    El valor de la configuración query.source.batching es false.

  3. Para cambiar el valor de la configuración query.source.batching a true, ejecute el comando /usr/ITFM-Cloud/va-tools/bin/configclient.py SET -k query.source.batching -v true.
  4. Para comprobar que el valor de la configuración query.source.batching es true, ejecute el comando /usr/ITFM-Cloud/va-tools/bin/configclient.py GET -k query.source.batching.
  5. Para reiniciar la máquina virtual de vRealize Business for Cloud, ejecute el comando monit restart itbm-server.

    Después de reiniciar la máquina virtual de vRealize Business for Cloud, el estado de cálculo de costes es de color verde.