Los Log Insight Agents rechazan el certificado autofirmado.

Problema

Un agente de vRealize Log Insight rechaza el certificado autofirmado y no puede establecer una conexión con el servidor.

Nota: Si experimenta problemas de conexión con el agente, puede generar registros detallados y consultarlos. Para ello, cambie el nivel de depuración del agente a 1. Para obtener más información, consulte Definir el nivel de detalles de registro en los Log Insight Agents.

Causa

Los mensajes que aparecen en el registro del agente incluyen motivos específicos.

Message (Mensaje) Causa
Rechazo del certificado autofirmado del mismo nivel. La clave pública no coincide con la clave del certificado almacenada previamente.
  • Esto puede suceder cuando se reemplaza el certificado devRealize Log Insight.
  • Esto puede suceder si la HA habilitada en el entorno del clúster está configurada con certificados autofirmados diferentes en los nodos de vRealize Log Insight.
Rechazo del certificado autofirmado del mismo nivel. Tiene un certificado recibido previamente que fue firmado por una CA de confianza. Hay un certificado firmado por una CA almacenado en el agente.

Solución

  • Verifique si su nombre de host de destino es una instancia de vRealize Log Insight de confianza y luego elimine manualmente el certificado previo del agente de vRealize Log Insight, directorio cert.
    • Para Log Insight Windows Agent, vaya a C:\ProgramData\VMware\Log Insight Agent\cert.
    • Para Log Insight Linux Agent, vaya a /var/lib/loginsight-agent/cert.
    Nota: Algunas plataformas pueden usar rutas de acceso no estándar para almacenar certificados de confianza. Los Log Insight Agents tienen una opción que permite configurar la ruta de acceso al almacén de certificados de confianza estableciendo el parámetro de configuración ssl_ca_path=<fullpath>. Reemplace <fullpath> por la ruta de acceso al archivo del paquete de certificados raíz de confianza. Consulte Configurar los parámetros SSL de agentes de Log Insight.