Una configuración incorrecta puede evitar que los agentes de vRealize Log Insight reenvíen registros al servidor de vRealize Log Insight. Si un canal de recopilación de archivos no está correctamente configurado, puede ver mensajes como “Invalid settings were obtained for channel 'CHANNEL_NAME'. Channel 'CHANNEL_NAME' will stay dormant until properly configured”.

Problema

Las instancias de los agentes de vRealize Log Insight aparecen en la página Agente > de administración, pero no aparecen registros en la página Análisis interactivo de los nombres de host de los agentes de vRealize Log Insight. El canal de recopilación de archivos planos no está correctamente configurado.

Causa

Una configuración incorrecta puede evitar que los agentes de vRealize Log Insight reenvíen registros al servidor de vRealize Log Insight.

Solución

  • Defina un canal de recopilación válido. Verifique si el canal de recopilación de archivos planos está correctamente configurado. Consulte Configurar agentes de vRealize Log Insight.
  • Para el agente de Windows de vRealize Log Insight, intente lo siguiente.
    • Si los canales de Windows están habilitados, vea el contenido de los archivos de registro del agente de Windows de vRealize Log Insight situados en %ProgramData%\VMware\Log Insight Agent\log. Busque mensajes de registro relacionados con la configuración de canales que incluyen las frases Subscribed to channel CHANNEL_NAME. Los canales que se usan con frecuencia son Application, System y Security.
    • Si un canal no está configurado correctamente, puede ver mensajes de registro similares a Could not subscribe to channel CHANNEL_NAME events. Código de error: 15007. No se pudo encontrar el canal especificado. Compruebe la configuración del canal. Puede ver un número de código de error diferente a 15007.
    • Si un canal de recopilación de archivos no está correctamente configurado, puede ver mensajes como Invalid settings were obtained for channel 'CHANNEL_NAME'. Channel 'CHANNEL_NAME' will stay dormant until properly configured
  • Para el agente de Windows de vRealize Log Insight y el agente de Linux de vRealize Log Insight, intente lo siguiente.
    • Si no hay canal de recopilación de archivos planos configurado, puede ver mensajes similares a Cannot find section 'filelog' in the configuration. The flat file log collector will stay dormant until properly configured
      El contenido de los archivos de registro de los agentes de vRealize Log Insight está situado en los siguientes directorios.
      • Windows: %ProgramData%\VMware\Log Insight Agent\log
      • Linux: /var/log/loginsight-agent/

Qué hacer a continuación

Para obtener más información sobre la configuración de los agentes de vRealize Log Insight, consulte Configurar Log Insight Windows Agent y Configurar Log Insight Linux Agent.