El proceso de definición de datos incluye añadir propiedades, métricas, políticas o datos que los adaptadores proporcionan a una vista. Estos son los elementos mediante lo que vRealize Operations Manager colecciona, calcula y presenta la información de la vista.

Para añadir datos a una vista, en el menú, haga clic en Paneles y, a continuación, en el panel izquierdo, haga clic en Vistas. En la barra de herramientas de Vistas, haga clic en el signo de más para añadir una vista o en el lápiz para editar la vista seleccionada. En la parte izquierda del área de trabajo, haga clic en Datos. Si crea una nueva vista, complete los pasos previos requeridos.

Cómo añadir datos a una vista

Si selecciona más de un asunto, especifique a cuál se añadirán datos. Haga doble clic en los datos del árbol del panel izquierdo para añadirlos a la vista. Para cada asunto, los datos disponibles para añadir pueden ser diferentes.

Cómo configurar la transformación de datos

Las opciones de configuración de los datos dependen de la vista y de los tipos de datos que seleccione. La mayoría de las opciones están disponibles para todas las vistas.

Tabla 1. Opciones de configuración de datos

Opciones de configuración

Descripción

Nombre de métrica

Nombre de métrica predeterminado

Disponible para todas las vistas.

Etiqueta de métrica

Etiqueta personalizable que aparece en la vista o en el informe.

Disponible para todas las vistas.

Unidades

Depende de la métrica o propiedad añadida. Puede seleccionar en qué unidad desea mostrar los valores. Por ejemplo, en CPU|Demanda (MHz) del menú desplegable Unidades, puede cambiar el valor a Hz, KHz o GHz. Si selecciona Automático, la escalabilidad se establece en una unidad significativa.

Disponible para todas las vistas.

Orden de clasificación

Ordena los valores en orden ascendente o descendente.

Disponible para la vista de Lista y Resumen.

Transformación

Determina qué método de cálculo se aplica a los datos sin procesar. Puede seleccionar el tipo de transformación:

  • Mínimo. El valor mínimo de la métrica a lo largo del rango de tiempo seleccionado.

  • Máximo. El valor máximo de la métrica a lo largo del rango de tiempo seleccionado.

  • Promedio. El promedio de todos los valores de la métrica a lo largo del rango de tiempo seleccionado.

  • Suma. La suma de los valores de la métrica a lo largo del rango de tiempo seleccionado.

  • Último. Ignora todos los datos excepto los que ha recibido más recientemente y que están dentro del rango de tiempo seleccionado.

  • Desviación estándar. La desviación estándar de los valores de las métricas.

  • Correlación de métricas. Muestra el valor cuando otra métrica está al mínimo o al máximo. Por ejemplo, muestra el valor de memory.usage cuando cpu.usage está al máximo.

  • Previsión. Realiza un análisis regresivo y predice los valores futuros. Muestra el último valor de métrica del rango seleccionado.

Disponible para todas las vistas, excepto para Tendencia.

Serie de datos

Puede seleccionar si desea incluir datos históricos, tendencias de datos históricos y la previsión del futuro en los cálculos de la vista de la tendencia.

Disponible para la vista Tendencia.

Acumulación de series

El intervalo de tiempo en el que se han implementado los datos. Puede seleccionar una de las opciones disponibles. Por ejemplo, si selecciona Sum como una transformación y 5 minutos como el intervalo de implementación, el sistema selecciona valores de intervalo de 5 minutos y los suma.

Esta opción se aplica a la opción de configuración de transformación.

Disponible para todas las vistas.

Proyectos

Un proyecto contiene escenarios y es una suposición de cómo cambia la capacidad y la carga si cambian ciertas condiciones, sin realizar cambios reales en su infraestructura virtual. Si implementa el proyecto, sabrá con antelación cuáles son sus requisitos de capacidad.

Disponible para todas las vistas. Depende de las métricas y propiedades seleccionadas.

Cómo ajustar la configuración de la hora

Utilice la configuración de la hora para seleccionar el intervalo de tiempo de la transformación de datos. Estas opciones están disponibles para todos los tipos de vistas, excepto para Imagen.

Puede establecer un rango de tiempo de un período pasado o datos futuros para la finalización del período de tiempo. Cuando seleccione datos de finalización futuros y no haya datos disponibles, la vista se rellenará con datos de previsión.

Tabla 2. Opciones de Configuración de hora

Opciones de configuración

Descripción

Modo de rango de tiempo

En el modo Básico, puede seleccionar rangos de tiempo.

En el modo Avanzado, puede seleccionar cualquier combinación de fechas de inicio y finalización relativas o específicas.

Rango de fechas relativo

Seleccione un rango de fechas relativo de la transformación de datos.

Disponible en el modo Básico.

Rango de fechas específico

Seleccione un rango de fechas específico de la transformación de datos.

Disponible en el modo Básico.

Rango de fechas absoluto

Seleccione un rango de fechas o de horas para ver los datos de una unidad de tiempo, como un mes completo o una semana. Por ejemplo, puede ejecutar un informe el tercer día de cada mes correspondiente al mes anterior. Los datos del primer día hasta el último del mes anterior se muestran en relación con los datos del tercer día del mes anterior hasta el tercer día del mes actual.

Las unidades de tiempo disponibles son: Horas, Días, Semanas, Meses y Años.

La configuración regional del sistema determina el inicio y el fin de la unidad. Por ejemplo, las semanas en la mayoría de los países de Europa empiezan el lunes, mientras que en Estados Unidos empiezan el domingo.

Disponible en el modo Básico.

Fecha de inicio relativa

Seleccione una fecha de inicio relativa de la transformación de datos.

Disponible en el modo Avanzado.

Fecha de finalización relativa

Seleccione una fecha de finalización relativa de la transformación de datos.

Disponible en el modo Avanzado.

Fecha de inicio específica

Seleccione una fecha de inicio específica de la transformación de datos.

Disponible en el modo Avanzado.

Fecha de finalización específica

Seleccione una fecha de finalización específica de la transformación de datos.

Disponible en el modo Avanzado.

Rango de fechas seleccionado actualmente

Muestra el rango de fechas o de horas seleccionado. Por ejemplo, si selecciona un rango de fechas específico del 01/05/2016 al 18/05/2016, se muestra la información siguiente: May 1, 2016 12:00:00 AM to May 18, 2016 11:55:00 PM.

Cómo desglosar datos

Para desglosar datos en las vistas de listas, añada columnas de desglose de intervalos o de instancias de la pestaña Agrupar por.

Tabla 3. Opciones Agrupar por

Opción

Descripción

Añada una columna de desglose de intervalo (consulte los datos de la configuración de columnas)

Seleccione la opción para ver los datos del desglose de los recursos seleccionados en intervalos de tiempo.

En la pestaña Datos, seleccione Desglose de instancia para configurar la columna. Puede introducir una etiqueta y seleccionar un intervalo de desglose para el rango de tiempo.

Añada una columna de desglose de instancia (consulte los datos de la configuración de columnas)

Seleccione esta opción para ver los datos de todas las instancias de los recursos seleccionados.

En la pestaña Datos, seleccione Nombre de instancia para configurar la columna. Puede introducir una etiqueta y seleccionar un grupo de métricas para desglosar todas las instancias de ese grupo. Anule la selección Mostrar la métrica agregada sin instancia para visualizar solo las instancias independientes. Anule la selección Mostar la métrica agregada sin instancia para visualizar el nombre del grupo de métricas y el nombre de la instancia de la columna de desglose de instancia.

Por ejemplo, para crear una vista para mostrar el uso de la CPU, seleccione la métrica CPU:0|Uso. Si añade una columna de desglose de instancia, la columna CPU:0|Uso muestra el uso de todas las instancias de la CPU en filas independientes (0, 1 y así sucesivamente). Para evitar la ambigüedad, puede cambiar la etiqueta de la métrica de CPU:0|Uso a Uso.

Cómo añadir un filtro

Las opciones de filtrado le permiten añadir criterios adicionales cuando la vista muestra demasiada información. Por ejemplo, una vista de lista muestra información sobre el mantenimiento de las máquinas virtuales. En la pestaña Filtro puede añadir una métrica de riesgo inferior al 50 %. A continuación, la vista mostrará el mantenimiento de todas las máquinas virtuales con un riesgo inferior al 50 %.

Para añadir un filtro a una vista, seleccione Contenido > Vistas en el panel izquierdo. En la barra de herramientas de Vistas, haga clic en el signo de más para añadir una vista o en el lápiz para editar la vista seleccionada. En el área de trabajo, a la izquierda, haga clic en Datos y en la pestaña Filtro del panel principal. Si crea una nueva vista, complete los pasos previos requeridos.

Cada asunto tiene un cuadro de filtros independiente. En los asuntos Acumulación de alertas, Alerta y Síntoma, no todas las métricas son compatibles para el filtrado.

Tabla 4. Opciones de adición del filtro

Opción

Descripción

Añadir

Añade otro criterio al conjunto de criterios. El filtro devuelve los resultados que coinciden con todos los criterios especificados.

Añadir otro criterio

Añade otro conjunto de criterios. El filtro devuelve los resultados que coinciden con un conjunto de criterios o de otro tipo.

Cómo añadir una fila o una columna de resumen a una vista

La opción de resumen está disponible solo para las vistas de Lista y Resumen. Es obligatoria en las vistas de Resumen. Puede añadir más de una fila o columna de resumen y configurar cada una para mostrar las diferentes agregaciones. En el panel de configuración de resumen, seleccione el método de agregación y qué datos desea incluir o excluir de los cálculos.

Para añadir una fila o columna de resumen a una vista, seleccione Contenido > Vistas en el panel izquierdo. En la barra de herramientas de Vistas, haga clic en el signo de más para añadir una vista o en el lápiz para editar la vista seleccionada. En el área de trabajo, a la izquierda, haga clic en Datos y en la pestaña Resumen del panel principal. Si crea una nueva vista, complete los pasos previos requeridos.

En la vista Lista, la fila de resumen muestra la información agregada por los asuntos especificados.

En la vista Resumen, la columna de resumen muestra la información agregada por los elementos proporcionados en la pestaña Datos.