Es posible que reciba un error al supervisar el complemento de RabbitMQ.

Problema

Al supervisar el complemento de RabbitMQ, puede producirse un error si actualiza a vRealize Operations Cloud, que tiene una versión de Telegraf 1.19. Se muestra el siguiente mensaje:

getting "/api/federation-links" failed: 404 Not Found

Causa

Los complementos de Federation en la configuración de RabbitMQ no están habilitados.

Solución

  • Habilite los complementos de Federation en la configuración de RabbitMQ ejecutando los siguientes comandos en la máquina virtual de RabbitMQ:
    rabbitmq-plugins enable rabbitmq_federation
    
    rabbitmq-plugins enable rabbitmq_federation_management