Lorsque vous tentez d'ouvrir une machine virtuelle Horizon FLEX pour la première fois, vous recevez un message indiquant que le serveur de gestion des restrictions n'a pas pu être contacté.

Problème

Lorsque vous tentez d'ouvrir une machine virtuelle Horizon FLEX pour la première fois, le serveur de gestion des restrictions ne peut pas être contacté.

Cause

Cette erreur se produit, car votre système d'exploitation ne fait pas confiance au certificat du Horizon FLEX Serveur. L'erreur peut également se produire si l'utilisateur est hors ligne ou si le serveur Horizon FLEX est en panne.

Solution

  1. Vérifiez auprès de votre administrateur Horizon FLEX que le certificat est valide pour le Horizon FLEX Serveur.
    Important : N'exécutez pas cette tâche si le certificat n'est pas valide.
  2. Si vous utilisez Fusion Pro, installez le certificat du Horizon FLEX Serveur sur votre Mac.
    1. Dans votre navigateur, accédez à l'URL du Horizon FLEX Serveur.
      Par exemple : https://yourserver:7443
    2. Acceptez l'avertissement de certificat pour enregistrer le certificat.
    3. Ouvrez l'application KeyChain.
    4. Recherchez le certificat sous Ouverture de session et faites-le glisser dans Système.
    5. Ouvrez le certificat sous Système. Développez le bouton Approuver, sélectionnez Réglages par défaut et fermez le certificat.
    6. Rouvrez le certificat sous Système, développez Approuver, sélectionnez Toujours approuver et fermez le certificat.
      Le certificat est maintenant approuvé pour tous les utilisateurs sur le Mac.
  3. Si vous utilisez Workstation Player, installez le certificat du Horizon FLEX Serveur sur votre système Windows.
    1. Dans votre navigateur, accédez à l'URL d'Horizon FLEX.
      Par exemple : https://yourserver:7443/rvm
    2. Cliquez sur l'icône de verrou dans la barre d'adresse.
    3. Cliquez sur Informations sur le certificat.
    4. Dans l'onglet Détails, cliquez sur Copier dans un fichier et exportez le certificat dans un fichier.
    5. Démarrez MMC (mmc.exe).
    6. Sélectionnez Fichier > Ajouter/Supprimer un composant logiciel enfichable.
    7. Cliquez sur le composant logiciel enfichable Certificats et cliquez sur Ajouter.
    8. Dans la fenêtre Composant logiciel enfichable Certificats, sélectionnez Compte d'ordinateur et cliquez sur Suivant.
      Ce paramètre est requis par Horizon FLEX Serveur.
    9. Sélectionnez Ordinateur local et cliquez sur Terminer, puis sur OK.
    10. Dans le volet de navigation de gauche, développez Certificats (ordinateur local).
    11. Cliquez avec le bouton droit sur Autorités de certification racines de confiance et sélectionnez Toutes les tâches > Importer.
      L'Assistant Importation de certificat s'ouvre.
    12. Cliquez sur Suivant.
    13. Recherchez le fichier de certificat racine et cliquez sur Suivant.
    14. Sélectionnez Placer tous les certificats dans le magasin suivant : Autorités de certification racines de confiance et cliquez sur Suivant, puis sur Terminer.
      Le certificat est maintenant approuvé pour tous les utilisateurs sur votre ordinateur Windows.