Site Recovery Manager dépend d'autres services. Si l'un de ces services n'est pas en cours d'exécution, Serveur Site Recovery Manager ne démarre pas.
Problème
Cause
Serveur Site Recovery Manager peut ne pas démarrer si vCenter Server n'est pas en cours d'exécution, s'il ne peut pas se connecter à la base de données Site Recovery Manager ou si d'autres services requis par Site Recovery Manager sont en cours d'exécution.
Solution
- Vérifiez le fichier journal le plus récent de Serveur Site Recovery Manager et l'Observateur d'événements Windows pour vous assurer qu'ils ne contiennent pas d'erreurs.
La plupart des erreurs figurent dans le fichier journal de Serveur Site Recovery Manager. D'autres erreurs peuvent s'afficher dans l'Observateur d'événements Windows. Par exemple, la base de données de Site Recovery Manager s'initialise avant le démarrage du service de journalisation de Site Recovery Manager. Si des erreurs se produisent pendant l'initialisation de la base de données, elles s'affichent dans l'Observateur d'événements Windows. Les erreurs liées à la validité du certificat s'affichent également dans l'Observateur d'événements Windows.
- Vérifiez que l'instance de vCenter Server étendue par Site Recovery Manager est en cours d'exécution.
Si le service vCenter Server s'exécute sur un hôte différent de Serveur Site Recovery Manager et que le service vCenter Server s'arrête, Serveur Site Recovery Manager démarre correctement, puis s'arrête peut de temps après.
- Vérifiez que le service de base de données Site Recovery Manager est en cours d'exécution.
Si vous utilisez la base de données intégrée, vérifiez que le service VMware Postgres est en cours d'exécution. Si vous utilisez une base de données externe, vérifiez que le service SQL Server ou Oracle Server approprié est en cours d'exécution.
- Connectez-vous à la machine sur laquelle vous avez installé Serveur Site Recovery Manager.
- Vérifiez que Site Recovery Manager peut se connecter à vCenter Server.
- Ouvrez Programmes et Fonctions à partir du panneau de configuration de Windows.
- Sélectionnez l'entrée VMware vCenter Site Recovery Manager, puis cliquez sur Modifier.
- Cliquez sur Suivant.
- Sélectionnez Modifier.
- Vérifiez que l'adresse de vCenter Server est correcte.
Si l'adresse de vCenter Server a été modifiée depuis que vous avez installé Site Recovery Manager (par exemple, si la machine vCenter Server utilise DHCP plutôt qu'une adresse statique), supprimez Site Recovery Manager, puis réinstallez-le et reconfigurez-le.
- Entrez le mot de passe de vCenter Server, puis cliquez sur Suivant.
Si le mot de passe de vCenter Server a changé depuis que vous avez installé Site Recovery Manager, entrez le nouveau mot de passe.
- Sélectionnez Utiliser le certificat existant, puis cliquez sur Suivant.
- Vérifiez que les informations d'identification de la base de données Site Recovery Manager sont correctes.
- Vérifiez que la base de données Site Recovery Manager autorise suffisamment de connexions.
Si les journaux de Site Recovery Manager contiennent le message GetConnection: Still waiting for available connections, augmentez le nombre maximum de connexions à la base de données. Consultez votre administrateur de base de données avant de modifier ces paramètres.
- Cliquez sur Suivant.
Si la connexion à la base de données échoue, fermez le programme d'installation de Site Recovery Manager et accédez à Étape 6.
- Sélectionnez Utiliser les données existantes, puis cliquez sur Suivant.
- Vérifiez que le compte d'utilisateur du service Site Recovery Manager est correct et cliquez sur Suivant.
Si vous utilisez un compte différent du compte Système local, vérifiez que le nom d'utilisateur et le mot de passe sont corrects.
- Cliquez sur Installer pour mettre à jour la configuration de Site Recovery Manager ou cliquez sur Annuler si vous n'avez effectué aucune modification.
- Vérifiez que Site Recovery Manager peut se connecter à la base de données Site Recovery Manager.
- Ouvrez l'utilitaire administrateur de sources de données ODBC de Windows, C:\Windows\System32\Odbcad32.exe.
- Sélectionnez le DSN système de Site Recovery Manager et cliquez sur Configurer.
- Vérifiez les paramètres de base de données.
- Vérifiez que le serveur de base de données auquel Site Recovery Manager tente de se connecter est correct.
- Vérifiez que les informations d'identification de connexion de la base de données Site Recovery Manager sont correctes.
- Vérifiez que la méthode d'authentification est correcte.
- Cliquez sur Tester la source de données.
Si la connexion est configurée correctement, la fenêtre Test de source de données ODBC affiche un résultat positif.
- Si le test de connexion échoue, reconfigurez la base de données Site Recovery Manager à l'aide du logiciel d'administration de votre fournisseur de base de données.
- Ouvrez l'utilitaire Windows Server Manager et sélectionnez Configuration > Services.
- Vérifiez que les services requis par Site Recovery Manager sont en cours d'exécution.
- Windows Server
- Windows Workstation
- Stockage protégé
- Sélectionnez le service VMware vCenter Site Recovery Manager Server dans l'utilitaire Gestionnaire de serveur Windows, puis cliquez sur Démarrer ou Redémarrer.