Site Recovery Manager dépend d'autres services. Si l'un de ces services n'est pas en cours d'exécution, Site Recovery Manager Server ne démarre pas.
Problème
Après avoir installé, réparé ou modifié Site Recovery Manager en exécutant le programme d'installation de Site Recovery Manager, ou après avoir redémarré Site Recovery Manager Server, Site Recovery Manager Server ne démarre pas ou il démarre, puis s'arrête.
Cause
Site Recovery Manager Server peut ne pas démarrer si vCenter Server n'est pas en cours d'exécution, s'il ne peut pas se connecter à la base de données Site Recovery Manager ou si d'autres services requis par Site Recovery Manager sont en cours d'exécution.
Solution
- Vérifiez le fichier journal le plus récent de Site Recovery Manager Server et l'Observateur d'événements Windows pour vous assurer qu'ils ne contiennent pas d'erreurs.
La plupart des erreurs figurent dans le fichier journal de Site Recovery Manager Server. D'autres erreurs peuvent s'afficher dans l'Observateur d'événements Windows. Par exemple, la base de données de Site Recovery Manager s'initialise avant le démarrage du service de journalisation de Site Recovery Manager. Si des erreurs se produisent pendant l'initialisation de la base de données, elles s'affichent dans l'Observateur d'événements Windows. Les erreurs liées à la validité du certificat s'affichent également dans l'Observateur d'événements Windows.
- Vérifiez que l'instance de vCenter Server étendue par Site Recovery Manager est en cours d'exécution.
Si le service vCenter Server s'exécute sur un hôte différent de Site Recovery Manager Server et que le service vCenter Server s'arrête, Site Recovery Manager Server démarre correctement, puis s'arrête peut de temps après.
- Vérifiez que le service de base de données Site Recovery Manager est en cours d'exécution.
Si vous utilisez la base de données intégrée, vérifiez que le service VMware Postgres est en cours d'exécution.
Si vous utilisez une base de données externe, vérifiez que le service SQL Server ou Oracle Server approprié est en cours d'exécution.
- Connectez-vous à la machine sur laquelle vous avez installé Site Recovery Manager Server.
- Exécutez le programme d'installation de Site Recovery Manager en mode de modification pour vérifier que l'installation est correctement configurée.
Pour faciliter les modifications d'adresse IP dans votre infrastructure, fournissez un nom de domaine complet (FQDN) chaque fois que possible, plutôt qu'une adresse IP.
Vérifiez que l'adresse de Platform Services Controller est correcte.
Si le mot de passe de vCenter Single Sign-On a changé depuis que vous avez installé Site Recovery Manager, entrez le nouveau mot de passe.
Vérifiez que l'adresse de vCenter Server est correcte. Si l'adresse de vCenter Server a été modifiée depuis que vous avez installéSite Recovery Manager (par exemple, si la machine Site Recovery Manager utilise DHCP plutôt qu'une adresse statique), supprimez Site Recovery Manager, puis réinstallez-le et reconfigurez-le.
Vérifiez que l'adresse de l'hôte local de Site Recovery Manager Server est correcte.
Vérifiez que les informations d'identification de la base de données Site Recovery Manager sont correctes.
Vérifiez que la base de données Site Recovery Manager autorise suffisamment de connexions. Si les journaux Site Recovery Manager contiennent le message GetConnection: Still waiting for available connections, augmentez le nombre maximum de connexions à la base de données. Consultez votre administrateur de base de données avant de modifier ces paramètres.
Vérifiez que le compte d'utilisateur du service Site Recovery Manager est correct. Si vous utilisez un compte différent du compte Système local, vérifiez que le nom d'utilisateur et le mot de passe sont corrects.
Pour faciliter les modifications d'adresse IP dans votre infrastructure, fournissez un nom de domaine complet (FQDN) chaque fois que possible, plutôt qu'une adresse IP.
- Exécutez l'utilitaire administrateur de sources de données ODBC de Windows pour vérifier que Site Recovery Manager peut se connecter à la base de données Site Recovery Manager.
- Ouvrez l'utilitaire Windows Server Manager et sélectionnez .
- Vérifiez que les services requis par Site Recovery Manager sont en cours d'exécution.
Windows Server
Windows Workstation
Stockage protégé
- Sélectionnez le service VMware vCenter Site Recovery Manager Server dans l'utilitaire Gestionnaire de serveur Windows, puis cliquez sur Démarrer ou Redémarrer.