Site Recovery Manager dépend d'autres services. Si l'un de ces services n'est pas en cours d'exécution, Site Recovery Manager Server ne démarre pas.
Problème
Après avoir installé, réparé ou modifié
Site Recovery Manager en exécutant le programme d'installation de
Site Recovery Manager, ou après avoir redémarré
Site Recovery Manager Server,
Site Recovery Manager Server ne démarre pas ou il démarre, puis s'arrête.
Cause
Le serveur Site Recovery Manager Server peut ne pas démarrer si l'instance de Platform Services Controller ou de vCenter Servern'est pas en cours d'exécution, s'il ne peut pas se connecter à la base de données de Site Recovery Manager ou si d'autres services requis par Site Recovery Manager ne sont pas en cours d'exécution.
Solution
- Vérifiez le fichier journal le plus récent de Site Recovery Manager Server et l'Observateur d'événements Windows pour vous assurer qu'ils ne contiennent pas d'erreurs.
La plupart des erreurs figurent dans le fichier journal de
Site Recovery Manager Server. Reportez-vous à la section
Collecte des fichiers journaux de Site Recovery Manager dans le Guide
Administration de Site Recovery Manager. D'autres erreurs peuvent s'afficher dans l'Observateur d'événements Windows. Par exemple, la base de données de
Site Recovery Manager s'initialise avant le démarrage du service de journalisation de
Site Recovery Manager. Si des erreurs se produisent pendant l'initialisation de la base de données, elles s'affichent dans l'Observateur d'événements Windows. Les erreurs liées à la validité du certificat s'affichent également dans l'Observateur d'événements Windows.
- Vérifiez que les instances de Platform Services Controller et de vCenter Server que Site Recovery Manager étend sont en cours d'exécution.
Si le service
Platform Services Controller ou
vCenter Server s'exécute sur un hôte différent de
Site Recovery Manager Server et que le service
vCenter Server s'arrête,
Site Recovery Manager Server démarre correctement, puis s'arrête peu de temps après.
- Vérifiez que le service de base de données Site Recovery Manager est en cours d'exécution.
- Si vous utilisez la base de données intégrée, ouvrez l'utilitaire Windows Server Manager sur l'hôte Site Recovery Manager et sélectionnez pour vérifier que le service de la base de données intégrée de VMware vCenter Site Recovery Manager est en cours d'exécution.
- Si vous utilisez une base de données externe, vérifiez que le service SQL Server ou Oracle Server approprié est en cours d'exécution sur l'hôte de la base de données.
- Connectez-vous à la machine sur laquelle vous avez installé Site Recovery Manager Server.
- Exécutez le programme d'installation de Site Recovery Manager en mode de modification pour vérifier que l'installation est correctement configurée.
Pour faciliter les modifications d'adresse IP dans votre infrastructure, fournissez un nom de domaine complet (FQDN) chaque fois que possible, plutôt qu'une adresse IP.
- Vérifiez que l'adresse de Platform Services Controller est correcte.
- Si le mot de passe de vCenter Single Sign-On a changé depuis que vous avez installé Site Recovery Manager, entrez le nouveau mot de passe.
- Vérifiez que l'adresse de vCenter Server est correcte. Si l'adresse de vCenter Server a été modifiée depuis que vous avez installéSite Recovery Manager (par exemple, si la machine Site Recovery Manager utilise DHCP plutôt qu'une adresse statique), supprimez Site Recovery Manager, puis réinstallez-le et reconfigurez-le.
- Vérifiez que l'adresse de l'hôte local de Site Recovery Manager Server est correcte.
- Vérifiez que les informations d'identification de la base de données Site Recovery Manager sont correctes.
- Vérifiez que la base de données Site Recovery Manager autorise suffisamment de connexions. Si les journaux Site Recovery Manager contiennent le message GetConnection: Still waiting for available connections, augmentez le nombre maximum de connexions à la base de données. Consultez votre administrateur de base de données avant de modifier ces paramètres.
- Vérifiez que le compte d'utilisateur du service Site Recovery Manager est correct. Si vous utilisez un compte différent du compte Système local, vérifiez que le nom d'utilisateur et le mot de passe sont corrects.
- Exécutez l'utilitaire administrateur de sources de données ODBC de Windows pour vérifier que Site Recovery Manager peut se connecter à la base de données Site Recovery Manager.
- Ouvrez C:\Windows\System32\Odbcad32.exe.
- Sélectionnez le DSN système de Site Recovery Manager et cliquez sur Configurer.
- Vérifiez les paramètres de base de données.
- Vérifiez que le serveur de base de données auquel Site Recovery Manager tente de se connecter est correct.
- Vérifiez que les informations d'identification de connexion de la base de données Site Recovery Manager sont correctes.
- Vérifiez que la méthode d'authentification est correcte.
- Cliquez sur Tester la source de données.
Si la connexion est configurée correctement, la fenêtre
Test de source de données ODBC affiche un résultat positif.
- Si le test de connexion échoue, reconfigurez la base de données Site Recovery Manager à l'aide du logiciel d'administration de votre fournisseur de base de données.
- Ouvrez l'utilitaire Windows Server Manager et sélectionnez .
- Vérifiez que les services requis par Site Recovery Manager sont en cours d'exécution.
- Windows Server
- Windows Workstation
- Stockage protégé
- Sélectionnez le service VMware vCenter Site Recovery Manager Server dans l'utilitaire Gestionnaire de serveur Windows, puis cliquez sur Démarrer ou Redémarrer.