Lorsque vous lancez un test de récupération ou une récupération réelle, des adaptateurs de réplication de stockage (SRA) envoient des réponses à Site Recovery Manager avant qu'un périphérique de stockage promu sur le site de récupération ne soit disponible pour les hôtes ESXi. Site Recovery Manager réanalyse les périphériques de stockage et la réanalyse échoue.
Problème
Si les périphériques de stockage ne sont pas encore totalement disponibles, ESXi Server ne les détecte pas et Site Recovery Manager ne trouve pas les périphériques répliqués lorsqu'il effectue la réanalyse. Cela risque d'entraîner plusieurs problèmes.
- Les banques de données ne sont pas créées et les machines virtuelles récupérées sont introuvables.
- Les hôtes ESXi ne répondent plus au signal de pulsation de vCenter Server et se déconnectent de vCenter Server. Si cela se produit ,vCenter Server envoie une erreur à Site Recovery Manager et le test de récupération ou la récupération réelle échoue.
- L'hôte ESXi est disponible, mais la réanalyse et la resignature de disques excèdent les délais d'attente de Site Recovery Manager ou de vCenter Server, entraînant une erreur Site Recovery Manager.
Cause
Les périphériques de stockage ne sont pas prêts lorsque Site Recovery Manager démarre la réanalyse.
Solution
Pour retarder le lancement des analyses de stockage jusqu'à ce que les périphériques de stockages soient disponibles sur les hôtes ESXi, augmentez le paramètre storageProvider.hostRescanDelaySec à une valeur comprise entre 20 et 180 secondes. Reportez-vous à Modifier les paramètres du fournisseur de stockage.