La reconfiguration de Site Recovery Manager échoue après la mise à niveau d'une instance de vCenter Server 6.5.x ou 6.7.x avec une instance externe de Platform Services Controller vers un nœud vCenter Server 7.x intégré.

Problème

Lorsque vous tentez de reconfigurer Site Recovery Manager après une mise à niveau d'une instance de vCenter Server 6.5.x ou 6.7.x avec un Platform Services Controller externe vers une instance de vCenter Server avec un nœud 7.x intégré, l'opération échoue avec une erreur.
ERROR
Operation Failed
A general system error occurred: 22ConfigurationException Failed to configure DR server with the Infrastructure Node services. Reason: Fault cause: lookup.fault.EntryExistsFault

Exit code: 61

Cause

Lorsque vous mettez à niveau une instance de vCenter Server 6.5.x ou 6.7.x avec une instance externe de Platform Services Controller vers une instance de vCenter Server 7.x avec un nœud intégré, l'ID de nom du site vCenter Single Sign-On est modifié.

Solution

  1. Enregistrez le serviceId à partir du message Error 61.
  2. Connectez-vous avec les informations d'identification de vCenter Serverà https://<vCenter_Server_address>/lookupservice/mob/ sur le site protégé.
  3. Accédez à RetrieveServiceContent > Appeler la méthode > ServiceRegistration > Supprimer la méthode pour supprimer serviceId: <serviceId>.
  4. Connectez-vous à l'interface de gestion du dispositif Site Recovery Manager sur le site protégé en tant qu'administrateur.
  5. Cliquez sur Résumé, cliquez sur Reconfigurer et suivez les invites.
  6. Enregistrez le serviceId à partir du message Error 61.
  7. Connectez-vous avec les informations d'identification de vCenter Serverà https://<vCenter_Server_address>/lookupservice/mob/ sur le site de récupération.
  8. Accédez à RetrieveServiceContent > Appeler la méthode > ServiceRegistration > Supprimer la méthode pour supprimer serviceId: <serviceId>.
  9. Connectez-vous à l'interface de gestion du dispositif Site Recovery Manager en tant qu'administrateur.
  10. Dans l'interface de gestion du dispositif Site Recovery Manager, cliquez sur Services.
  11. Sélectionnez le service srm-server, cliquez sur Arrêter, puis sur OK.
  12. Connectez-vous via SSH à l'instance intégrée de vCenter Server mise à niveau et notez le nom du site vCenter Single Sign-On.
    /usr/lib/vmware-vmafd/bin/vmafd-cli get-site-name --server-name localhost
  13. Connectez-vous via SSH à Site Recovery Manager, exécutez la commande suivante et notez le db_id.
    echo "select * from pds_solutionuser;" | PGPASSWORD='<mot de passe>' /opt/vmware/vpostgres/current/bin/psql -U srmdb -d srmdb -p 5432
    Note : Le mot de passe est le mot de passe de la base de données vPostgres intégrée que vous avez défini lors de l'installation de Site Recovery Manager.
  14. Exécutez la commande suivante.
    echo "update pds_solutionuser set siteid = 'default-first-site' where db_id =<db_id> ;" | PGPASSWORD='<password>' /opt/vmware/vpostgres/current/bin/psql -U srmdb -d srmdb -p 5432
  15. Connectez-vous à l'interface de gestion du dispositif Site Recovery Manager sur le site de récupération en tant qu'administrateur et reconfigurez Site Recovery Manager.
  16. Connectez-vous à Site Recovery Manager sur le site protégé.
  17. Sur l'onglet d'accueil de Site Recovery, sélectionnez une paire de sites et cliquez sur Afficher les détails.
  18. Sélectionnez Paire de sites > Résumé, puis cliquez sur Reconnecter.
    1. Si vous rencontrez une erreur, redémarrez les instances de Site Recovery Manager et vCenter Server, puis répétez l'opération de reconnexion.
      Unable to connect to Site Recovery Manager Server at https://<SRM FQDN/IP>:443/drserver/vcdr/vmomi/sdk. 
      Reason: java.net.SocketTimeoutException: 30,000 milliseconds timeout on connection http-outgoing-431 [ACTIVE]