Il se peut qu'un message d'erreur soit généré pendant le processus de récupération si l'utilisateur de la solution Site Recovery Manager ne dispose pas des autorisations nécessaires pour effectuer une personnalisation IP ou des appels de système d'exploitation invité.

Problème

Si l'utilisateur de la solution Site Recovery Manager ne dispose pas des autorisations appropriées pour accéder au système d'exploitation invité de la VM récupérée, il se peut que les messages d'erreur suivants soient émis pendant le processus de récupération.
GuestPermissionDenied
CannotAccessFile

Cause

Le problème survient lorsque l'utilisateur de la solution Site Recovery Manager est mappé à un utilisateur du système d'exploitation invité qui n'a pas accès à un fichier dans le système d'exploitation invité ou qui ne dispose pas des autorisations nécessaires pour exécuter des commandes.

Solution

  1. Si vous utilisez Site Recovery Manager pour configurer les mappages d'utilisateurs invités, assurez-vous que l'utilisateur du système d'exploitation invité qui exécute le service VMware Tools est autorisé à accéder à un fichier ou dispose des autorisations nécessaires pour exécuter des commandes.
    Pour plus d'informations sur l'activation ou la désactivation de la configuration automatique des mappages d'utilisateurs invités, reportez-vous à la section Modifier les paramètres de récupération.
  2. (Facultatif) Si vous configurez manuellement les mappages d'utilisateurs invités, mappez l'utilisateur local de la solution Site Recovery Manager du site de récupération à l'utilisateur du système d'exploitation invité disposant des autorisations appropriées.
  3. Exécutez à nouveau le plan de récupération.