Certaines mesures dépendent des API HelpDesk.

Problème

Mesures du service d'assistance manquantes en raison de l'API HelpDesk

Toutes les mesures de protocole, les performances historiques et les mesures d'application sur les sessions Horizon seront manquantes.

Cause

  1. L'indicateur « Activer la collecte des mesures de performance historique pour RDS » défini sur False désactive les mesures globales de CPU, de mémoire globale et d'IOPS de disque, et désactive les appels d'API HelpDesk pour les mesures de performance historiques.

  2. L'indicateur « Activer la collecte des mesures des performances du protocole » défini sur False désactive les mesures de fréquence d'images, de latence, de perte de paquets reçus, de perte de paquets transmis et d'utilisation de la bande passante, et désactive les appels d'API HelpDesk pour les mesures de protocole.

  3. L'indicateur « Activer la collecte des mesures d'application » défini sur False désactive les mesures d'utilisation du CPU et du disque, et désactive les appels d'API HelpDesk pour les sessions d'application Horizon.

  4. Le plug-in d'API HelpDesk n'est pas activé dans Horizon Agent, l'adaptateur ne pourra donc pas collecter de mesures. En tant que symptôme, vous observez le message d'erreur « ErrorCode=1001 - Unable to forward message to the AgentHelpDesk queue: NoQueueHandler » dans les journaux.

Solution

  1. Activez le plug-in du service d'assistance dans Horizon Agent et assurez-vous que les licences d'Horizon HelpDesk sont disponibles.

  2. Activer les indicateurs correspondants dans les paramètres avancés de l'adaptateur