Avant de déployer vCloud Director Object Storage Extension, vous devez préparer votre environnement. vCloud Director Object Storage Extension nécessite des composants externes spécifiques et prend en charge des versions spécifiques des composants externes.

Le tableau suivant répertorie les composants logiciels et les versions prises en charge des composants que vous devez déployer et configurer.
Composants requis Versions prises en charge
vCloud Director
  • 10
  • 9.7
  • 9.5
  • 9.1
Note : Pour être compatible avec vCloud Director Object Storage Extension, l'instance de vCloud Director que vous utilisez doit prendre en charge vCloud Director Service Provider Admin Portal et vCloud Director Tenant Portal.
Cloudian HyperStore Un cluster d'au moins 3 nœuds Cloudian HyperStore est requis.
  • Pour vCloud Director Object Storage Extension 1.0.1, installez et configurez Cloudian HyperStore 7.1.6.
  • Pour vCloud Director Object Storage Extension 1.0, installez et configurez Cloudian HyperStore 7.1.4.
Pour plus d'informations sur les spécifications requises de Cloudian HyperStore, reportez-vous à la section Configuration requise de Cloudian.
Base de données
  • PostgreSQL 10
  • PostgreSQL 9

vCloud Director Object Storage Extension nécessite une instance de base de données dédiée et un utilisateur de base de données disposant de privilèges suffisants pour créer des tables et modifier des schémas de base de données.

vCloud Director Object Storage Extension ne nécessite pas le bus de message RabbitMQ pour communiquer avec vCloud Director.